Hi all,

I have just populated the full planet file into my database (on top of an existing UK database install) and I'm now having some problems:

  1. Calling an is_in area query does not return any results for any new areas my database should now cover. It still returns the old UK areas however, but this leads me onto my second problem (possibly the same problem!)
  2. An is_in area call (in the UK or otherwise) does not return any admin_level 1 or 2 information, like it does on the Overpass API public server. This didn't happen pre-full planet installation but I assumed this was due to only having the UK installed, not multiple countries.
  3. The server now runs really slow! When it was just the UK, the server would process requests in a matter of milliseconds, now, since installing the planet, it takes 4-5 SECONDS to process a request! The RAM usage has escalated from ~75% while idle to ~99%. This happened before to me from populating a full UK install on top of an England only install on a different server. Restarting the server does not help.

The planet file I used is http://ftp.heanet.ie/mirrors/openstreetmap.org/planet/planet-latest.osm.bz2

I am baffled on this one and have no idea how to overcome it besides completely reinstalling the planet database. Is there a better way to solve this? Thanks!

asked 25 Aug '14, 14:31

gmeister4's gravatar image

gmeister4
608812
accept rate: 0%

edited 31 Mar '15, 20:38

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16236548

You didn't mention the Overpass API version you're using and how you're importing the data. Did you see any kind of warning/error message during the import?

Anyway, I'd recommend a fresh start, i.e. dump the current db or use a different db directory for the new import.

(25 Aug '14, 14:50) mmd

Oh sorry about that, I'm running version 0.7.4. I downloaded the planet .bz2 then executed the init_osm3s.sh script to build into the same directory of the original database. There were no error messages. I read on the wiki that you should be able to update the DB this way. Was it wrong to merge the database directory into an existing one? I guess this means that this method for updating part of the database is not recommended. All other queries I tested worked apart from the area search. Thanks for the advice!

(25 Aug '14, 15:52) gmeister4

judging from the question text of overpass-api-area-query-does-not-recognise-all-areas this particular "slow" problem may be solved. @gmeister4: Is it? How exactly?

If possible, please focus on one problem per question here on this help site (for more usefulness to other users with similar problems), unless you think that the problems may be due to the same reason, of course.

(31 Mar '15, 20:42) aseerel4c26 ♦
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×340
×225
×62
×26
×11

question asked: 25 Aug '14, 14:31

question was seen: 8,230 times

last updated: 31 Mar '15, 20:44

powered by OSQA