I have previously used MapInfo to convert and extract portions of OS OpenData and open it in JOSM, my preferred online editor. It has recently come to my attention that there is an offset of three metres, approximately, due south when comparing my own file with other OS OpenData already uploaded. I have tried ogr2ogr through FWTools but obtain the message, "Unable to open datasource 'SU_Woodland.shp' with the following drivers.". It then lists ->ESRI Shapefile, ->MapInfo File and about another thirty such items. I have tried all sorts of different combinations without success. Typically, I am entering, "ogr2ogr -t_srs WGS84 -s_srs EPSG:27700 osm.shp SU_Woodland.shp" to convert SU_Woodland shapefile in OS projection to osm shapefile in WGS84. I should add that the four shapefiles, .dbf, .prj, .shp, .shx, are in the same folder as FWTools247.exe.

Solved! I am hopeless with DOS: the Command Prompt opens with C:Program FilesFWTools2.4.7>. Of course, I have to change the path to where the executable file resides!

asked 07 Nov '11, 09:31

silver%20mapper's gravatar image

silver mapper
241262735
accept rate: 0%

closed 07 Nov '11, 10:03

Richard's gravatar image

Richard ♦
28.6k40253383

The question has been closed for the following reason "User has solved own question" by Richard 07 Nov '11, 10:03

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×3

question asked: 07 Nov '11, 09:31

question was seen: 2,139 times

last updated: 07 Nov '11, 10:03

powered by OSQA