NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Bonjour,

Nous avons une erreur 405 lors d'une requête POST vers l'API OpenStreetMap à l'aide de l'URL : 'http://nominatim.openstreetmap.org/search?q=CODE POSTAL&format=json&polygon=0&addressdetails=1'.

L'appel a toujours fonctionné sauf depuis le 31/07 à partir de 12h~12h30 où son fonctionnement alterne entre KO et OK. Sauriez-vous d'où cela peut venir ? Merci :)

asked 02 Aug '23, 15:35

Sylvain_1633's gravatar image

Sylvain_1633
11113
accept rate: 0%


You should be sending a GET request.

Sending a POST request was never documented and only worked incidentally. The new frontend implementation is more strict and will not allow POST anymore.

permanent link

answered 03 Aug '23, 12:30

lonvia's gravatar image

lonvia
6.2k25789
accept rate: 40%

Thanks a lot ! It works now !

(04 Aug '23, 10:47) Sylvain_1633

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×2

question asked: 02 Aug '23, 15:35

question was seen: 704 times

last updated: 04 Aug '23, 10:47

NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum