NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

After following the tutorial from Switch2OSM I ran into the following error after running this command: renderd -f -c /usr/local/etc/renderd.conf and launching the server through the web browser using this address: http://localhost/hot/0/0/0.png

renderd[64331]: An error occurred while loading the map layer 'ajt': Could not create datasource for type: 'postgis' (no datasource plugin directories have been successfully registered) encountered during parsing of layer 'landcover-low-zoom' in Layer at line 803 of '/home/user/src/openstreetmap-carto/mapnik.xml' renderd[64331]: DEBUG: Got incoming connection, fd 7, number 1 renderd[64331]: DEBUG: Got incoming request with protocol version 2 renderd[64331]: DEBUG: Got command RenderPrio fd(7) xml(ajt), z(0), x(0), y(0), mime(image/png), options() renderd[64331]: Received request for map layer 'ajt' which failed to load renderd[64331]: DEBUG: Sending render cmd(4 ajt 0/0/0) with protocol version 2 to fd 7 renderd[64331]: DEBUG: Connection 0, fd 7 closed, now 0 left

After doing some research I haven't found anything useful to solve this problem. Any help would be appreciated.

asked 01 Aug '23, 22:18

JaimeMiranda57's gravatar image

accept rate: 0%

edited 01 Aug '23, 22:23

I'm guessing that the bit that you're missing is the "While still working as the “postgres” user, set up PostGIS on the PostgreSQL database" part of that page.

Another possibility is that the "plugins_dir" setting in your "renderd.conf" is wrong - have a look below "/usr/lib/mapnik/" and see what there is.

permanent link

answered 01 Aug '23, 22:36

SomeoneElse's gravatar image

SomeoneElse ♦
accept rate: 16%

When I run the command createdb -E UTF8 -O myUsername gis the database is successfully created. After that I keep following the tutorial, type in psql in terminal, I get the "postgres=#" prompt, and right after that I type in \c gis and get the "You are now connected to database ‘gis’ as user 'postgres'". I'm guessing that that's what you mean by the first sentence in your answer? So to my understanding I am still working as the "postgres" user, correct? If that's not it I'm misunderstanding and if so, could you please clarify? Thanks.

I checked "/usr/lib/mapnik" and there's another folder inside that directory called "3.1". If I cd into that directory, there's another directory inside called "input". So, in essence, this is the path "/usr/lib/mapnik/3.1/input" and inside that I have 10 .input files.

(01 Aug '23, 23:17) JaimeMiranda57

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 01 Aug '23, 22:18

question was seen: 633 times

last updated: 01 Aug '23, 23:21

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum