NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Yesterday I was working on Umap all day. I took a short break in the evening, then, when I checked again, many elements/objects I had added were gone. Note that I save regularly, and only I can edit the map.

All objects still in place have as initial letters A to C; the rest is gone.

As I only used one layer, I checked the previous versions of this layer, however, all available ones (10 of them) had the objects missing.

What went wrong? Can I restore the map as it used to be?

asked 03 Jul '23, 15:12

Milo's gravatar image

accept rate: 0%

Can you share the map link so I can have a look ?

Also, can you try from another browser/network, in case it's a proxy cache issue ?

(03 Jul '23, 16:08) ybon

Hi, I already tried in Google Chrome, unfortunately that did nothing. The link is:

(03 Jul '23, 16:12) Milo

I have the same problem! Since sunday all data from my map have been lost. Does anybody know what could be the problem and what to do with it?

(04 Jul '23, 13:13) adamblazej

The map is private, so I cannot investigate. Can you add me as an editor temporarily (ybon) ?

(04 Jul '23, 13:20) ybon

Hi, I just added you as an editor to the map!

(04 Jul '23, 15:02) Milo

My problem has returned (2024)! Quite some of the changes I made yesterday have disappeared, but it's not as bas as last time. Can anyone help?

(26 Jan, 07:32) Milo
showing 5 of 6 show 1 more comments

Should be fixed, sorry!

permanent link

answered 04 Jul '23, 13:19

ybon's gravatar image

accept rate: 42%

Hi, will it still be fixed?

(11 Jul '23, 13:11) Milo

Humm, I don't understand why my comment is now an answer… I meant that adamblazej issue was fixed, not yours, sorry. And I don't have notifications when someone else comment where I've commented, so I missed your comment saying I'm now editor. I'll now investigate.

(11 Jul '23, 13:18) ybon

An invalid feature has been created with the name "Caf" (actually three features with that same name) and a null geometry. Maybe it's related to the "Cafan" feature ? Anyway, do you remember anything that could help understanding how those invalid features have been created ? So I can provide a fix for later. For this time, I've deleted manually those feature and reimported the layer. Please confirm it's ok.

(11 Jul '23, 13:33) ybon

@ybon moderators can change comments to answers and vice versa provided that they haven't been edited. I'm guessing that someone thought that your "Should be fixed, sorry!" applied to the original question :)

(11 Jul '23, 13:34) SomeoneElse ♦

Correct, that was my mistake. I thought the original problem had been fixed. Sorry :)

(11 Jul '23, 13:36) scai ♦

Ok, thanks for the explanation :)

Any idea why I do not receive a notification when someone comment after my comment ? I've tried to go in my settings, but I cannot touch those ones. I guess checking "A comment is posted" here would help, but I don't have the checkbox:

(11 Jul '23, 13:40) ybon

Wow! The data is indeed back, thank you very much! Unfortunately, I have no idea what could have caused it. I think the conversion of lines to polygons if the shapes were weird didn't always go right, but that wasn't with the Caf IIRC.

Btw, I admire this mapmaking service you guys have created! Cheers!

(11 Jul '23, 13:43) Milo

Re "Any idea why I do not receive a notification when someone comment after my comment ?" it's likely one of two things:

1) You've got it turned off in "notification settings"

2) It's a bug in OSQA.

FWIW I did get a notification about your comment ("ybon has just posted a comment on the answer posted by ybon to the question Umap: Lost data?"). Oddly, the subscriptions that I see for me don't seem to be editable, but presumably I set them when they were.

(11 Jul '23, 15:57) SomeoneElse ♦
showing 5 of 8 show 3 more comments

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 03 Jul '23, 15:12

question was seen: 693 times

last updated: 26 Jan, 07:32

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum