NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Somehow Vespucci editor was changed. I have no clue how to add or import or load a gpx track file to use it for tracing and painting new ways.

I tried add gpx layer in the 3 bar layer menu, but nothing shows up.

How does it work? Why is it not intuitive?

I am using Vespucci 18.0.5 on Android 10 and also on Android 8. Both have the same problem with different (all!!!) gpx files.

Edit: Finally works in Vespucci version 18.1.

asked 27 Nov '22, 20:51

erik's gravatar image

erik
558152234
accept rate: 9%

edited 30 Nov '22, 17:26

Adding a GPX file from within the app doesn't work for me either (no matter if it is located on the internal storage or the external SD card). Just nothing happens. However, opening a GPX file from within a file manager with Vespucci works. Android 10 here, all permissions for Vespucci (18.0.5.0) granted.

(29 Nov '22, 08:31) scai ♦

So they didn't test before delivering? Or can anybody tell that it works?

(29 Nov '22, 08:36) erik
1

As Simon wrote, Android's file access gets worse with each new Android version. Google invests a lot of work to make app development a PITA if raw access to arbitrary files is needed. I don't think you can blame the app developers for these bugs.

(29 Nov '22, 08:46) scai ♦

But it works on none of my phones, and they have different Android versions. And it used to work before on all of them with the old dialog to import gpx files.

(29 Nov '22, 09:35) erik

To be clear every release needs to pass our test suite which has multiple different tests for loading/importing/etc GPX files, and additionally some limited manual testing.

And naturally after your report I specifically tested manually yet again (on pre-Android 10), works without issue (scai hasn't reported his issue so I can't comment on that).

(29 Nov '22, 09:55) SimonPoole ♦

"Somehow": all user visible changes are documented in the release notes, in the specific case see http://vespucci.io/help/en/17.1.0%20Release%20notes/#improved-gpx-layer-support

Most problems with creating layers from files on the device stem from Android restrictions on file access that have progressively been getting stricter, unluckily you neither indicate which Vespucci version you are using, nor on which Android version you are running it. Without both bits of information it is rather difficult to diagnose what is happening.

Github issue: https://github.com/MarcusWolschon/osmeditor4android/issues/1959 Fix https://github.com/MarcusWolschon/osmeditor4android/pull/1962

The behaviour is actually an Android bug caused by both users that report this problem having a 3rd party file selector app installed in parallel to the system provided one and not selecting one of the two as the default.

permanent link

answered 28 Nov '22, 10:54

SimonPoole's gravatar image

SimonPoole ♦
44.7k13326701
accept rate: 18%

edited 30 Nov '22, 16:55

I have added the software versions. It has worked before when the GUI was different. The changelog doesn’t help.

(28 Nov '22, 12:06) erik

OK, then "nothing shows up" needs to be better defined, do you see a layer entry in the layer modal/dialog? Or do you have the entry and just don't see the contents of the layer?

(28 Nov '22, 12:13) SimonPoole ♦

Well, with “nothing” I mean nothing. No change at all visible. As if I hadn’t done anything. I don’t know how to better help with this. Debuglog? Is this possible? I would like to see a screencast how it should look like. I imagine a new layer that is called with the gpx file’s name. But I have seen it working on any phone.

(29 Nov '22, 09:36) erik
1

Well for starters this question has grown way past the scope of the help site.

You should open an issue on our repo via the "Provide feedback" function (main map display, overflow menu). Best would be to provide a short screen recording of what is happening (attached to a comment on the issue). You can further send in some debug information via the debug screen (again main map display) if you do that immediately after trying to add the layer it might be visible in the accompanying log (no guarantees), if you do submit debug information add a comment to it referencing the issue and notify us on the github issue.

(29 Nov '22, 10:03) SimonPoole ♦
(29 Nov '22, 10:28) SimonPoole ♦

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×255
×22
×13

question asked: 27 Nov '22, 20:51

question was seen: 1,082 times

last updated: 30 Nov '22, 17:26

NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum