NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Installing OS Map Tile server on a Redhat 8.x.x. I keep running into dependency-related issues. Also, I can't seem to find many guides on this.

Is this possible? If so, does anyone have a guide or work arounds?

asked 08 Nov '22, 01:45

Soulless_Solo's gravatar image

Soulless_Solo
11112
accept rate: 0%


Presumably you don't mean Redhat 8 from 2002 but actually RHEL 8 from 2022?

If so, this says it's based on Fedora 28 which isn't listed here although Fedora 33 and 34 are.

You have a few options:

  • Choose a more mainstream distribution for this sort of thing (recent Ubuntu or Debian)
  • Use something like Docker
  • Try and build as per Centos 7
  • Try and build as per Fedora 34

You haven't said what you have tried and what hasn't worked - presumably you're following either the Centos 7 instructions above or the Fedora 34 ones. Whichever you're following that doesn't work, try the other one.

However, you will be able to save yourself an awful lot of pain if you start from Debian 11 or Ubuntu 22.04 LTS, as described here.

permanent link

answered 08 Nov '22, 02:05

SomeoneElse's gravatar image

SomeoneElse ♦
36.9k71370866
accept rate: 16%

Thanks. I have tried Ubuntu 22 and that works fine without a hitch. But the environment I am in will only allow a RHEL 8 or a Windows instance.

(08 Nov '22, 02:09) Soulless_Solo

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×710
×30

question asked: 08 Nov '22, 01:45

question was seen: 1,281 times

last updated: 08 Nov '22, 02:10

NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum