NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I've created a couple of new tracks (highway=track), but I can't get OSM routing to use them, but it keeps creating a route the long way around, can someone please tell me what's wrong? https://www.openstreetmap.org/directions?engine=fossgis_osrm_foot&route=55.5459%2C12.1581%3B55.5385%2C12.1403

asked 21 Mar '22, 21:47

BjarneD's gravatar image

BjarneD
11112
accept rate: 0%

I am surprised you have so many tags on that track. What editor did you use? just curious. I'm using Potlatch and I think when I have looked at the history in the past it used to say which editor was used. I may be mistaken though :-)

(22 Mar '22, 15:04) andy mackey

@andy, I'm using the iOS app "Go Map!!" by which some default tags are added, and custom ones can also be added, and then I go to here to OSM to test it out.

(22 Mar '22, 19:45) BjarneD

Thanks I've not tried an iphone.

(22 Mar '22, 20:38) andy mackey

The openstreetmap database is is updated as soon as you save your edit. The router data will only be updated every few days, or week, or even longer. graphhopper is usually about four days in my experience. OSRM a bit longer.

permanent link

answered 22 Mar '22, 09:27

andy%20mackey's gravatar image

andy mackey
13.2k87143285
accept rate: 4%

1

Indeed the link is now showing a direct route over a new track so it looks like your edits were OK and are now reflected in this particular routing engine.

(22 Mar '22, 11:43) alan_gr

Thanks for telling about the latency in routing, I didn't know, and thought is was me that were doing something wrong :-)

(22 Mar '22, 19:48) BjarneD

It is the software you are using which seems to be set up for motor-vehicle restrictions eventhough you select foot. Basecamp does it correctly.link text Not much help I know but the only tag that restricts your routing is motor_vehicle=no

permanent link

answered 21 Mar '22, 22:41

wilda69's gravatar image

wilda69
18115
accept rate: 7%

The "pain" is OSM itself, which provide the capability to search route, and what you're indicating here is, that OSM is doing a really bad job itself... Or did I get that wrong?

(22 Mar '22, 19:38) BjarneD

We ( you as well BjameD ) are all helping on OSM for the love of maps and for free.... Or did I get it wrong? Getting involved with mapping, the forums and all the other stuff does, and should improve it.

(23 Mar '22, 07:37) andy mackey
1

"what you're indicating here is, that OSM is doing a really bad job itself" I'm not clear what you are referring to - I thought the routing is now working as expected?

(23 Mar '22, 08:01) alan_gr

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×179
×61
×37

question asked: 21 Mar '22, 21:47

question was seen: 1,187 times

last updated: 23 Mar '22, 08:01

NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum