0
1

Recently .osm files stopped loading in JOSM. When I try to open them, I get an error message that says "No data found in file (file name)" . I am using the newest version (4487) under Windows XP. Until recently the files opened fine. I can still open the .osm in notepad and view it. I tried saving it as an .xml file but with the same result. .xml files still open fine.

asked 08 Oct '11, 18:43

nmixter's gravatar image

nmixter
1319913
accept rate: 0%

closed 07 Mar '15, 08:23

SimonPoole's gravatar image

SimonPoole ♦
37.4k13281595

The question has been closed for the following reason "Obsolete" by SimonPoole 07 Mar '15, 08:23


I think we'd need to see the file, as I've just opened a .osm file in version 4487 without any problems (on Windows 7). Pastebin it somewhere, perhaps?

Alternatively, download an area in JOSM, save this as a .osm file and see if it can then reopen it, to try and see whether the problem is with your other file(s).

In case it makes a difference, the .osm file I opened was created using Osmosis cutting a polygon area out of a Geofabrik extract. I have just repeated the test by downloading an area, saving as .osm, quitting JOSM, restarting JOSM and loading the .osm file without problem.

permanent link

answered 09 Oct '11, 09:08

EdLoach's gravatar image

EdLoach ♦
17.6k14145254
accept rate: 23%

edited 09 Oct '11, 09:11

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×495
×75
×63

question asked: 08 Oct '11, 18:43

question was seen: 3,729 times

last updated: 07 Mar '15, 08:23

powered by OSQA