I've edited with Potlatch2 many, many times. Now it's not working; no editing is working. Zooming doesn't matter. It acts like I'm not logged in when, in fact, I am...

asked 05 Oct '11, 04:41

vkungys's gravatar image

vkungys
31113
accept rate: 0%

What browser are you usng? Which version of Flash Player?

(05 Oct '11, 09:04) Richard ♦

Upgrade your version of Flash player. Version 10.1.82.76 seems to be very buggy and has many known exploits.

I tested version 10.1.85.3 and Potlatch 2 seem to work fine.

permanent link
This answer is marked "community wiki".

answered 05 Oct '11, 12:41

Firefishy's gravatar image

Firefishy
1.2k73551
accept rate: 31%

edited 05 Oct '11, 12:42

3

www.osm.org now requires version 10.1.85 or greater.

(06 Oct '11, 10:59) Firefishy

I have the same problem/s, Potlatch is more or less un-usable. It started just a few days ago.

I'm using IE 8.0.6001 with Flash 10.1.82.76.

permanent link

answered 05 Oct '11, 09:46

Thavox's gravatar image

Thavox
39226
accept rate: 0%

If you try the test instance (not live data) at http://random.dev.openstreetmap.org/potlatch2/potlatch2.html , do you have the same problems? (Click "Cancel" if you get an "Authorisation Required" box.)

(05 Oct '11, 10:31) Richard ♦

It works better. Editing ways works fine, like creating new ways and deleting stuff.

But the drop down menu for tagging (to the left) have a life of it's own. It gets activated when I create a new road, wich blocks a large area of the edit screen, and sometimes it can't be activated at all.

The buttons down to the right are a bit tricky as well, they work fine but the shading is messed up so you really don't know when a button is available or not.

Update: The tagging-menues and button-shading works fine until the first time I tagg a way (as "Residential"). After that things get messed up.

(05 Oct '11, 11:24) Thavox

Hmmm. As a first step, you could try clearing your cache in case there are any old config files hanging around which are no longer compatible with the latest version of P2.

If that doesn't help, you could try installing the debug version of the Flash Player plug-in and reporting any error messages that it brings up (ideally through a ticket on trac.osm.org).

(05 Oct '11, 11:49) Richard ♦

Clearing the cache didn't help. I'll try upgrading my Flash later today...

(05 Oct '11, 13:36) Thavox

Have been looking into this and it's definitely a Flash 10.1.82 bug. Unfortunately there doesn't seem any easy way in which we can change P2 to cope with it.

(05 Oct '11, 13:40) Richard ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×312
×207

question asked: 05 Oct '11, 04:41

question was seen: 2,349 times

last updated: 06 Oct '11, 10:59

powered by OSQA