NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I have recently been linking the suburbs of Perth, Western Australia, to their corresponding Wikidata item so that the relevant English Wikipedia article can display the OSM map, which has been quite successful, except for eight instances, the eight suburbs of the City of Bayswater. Attempting to establish what could potentially cause this failure I have come across something that I lack the OSM experience for to understand. Maybe somebody could explain this to me: Taking the suburb of Bayswater, Western Australia as an example, when I do a search for it, I come up with just one item, the "Suburb", which is the relation (same result if I try Dianella, Western Australia, another suburb). If I pick a Perth suburb that works, Yokine, Western Australia, I get two results, "Suburb" and "Suburb boundary", the former being the Node, the later being the Relation. Now, the Bayswater Node does exist, I found it when searching the map in edit mode, but it does not show up in a search. Same with Dianella, both the relation and Node do exist but only the relation will show up in a general search. My questions are, why do the Nodes & Suburb boundaries for those two suburbs (Bayswater & Dianella) not show up in a general search, why does the Yokine "Suburb" link to the Node but the other two Suburbs to the relation, and could this be the cause for the maps not displaying properly? Any help or hint in this matter would be greatly appreciated!

asked 24 Oct '21, 08:31

Calistemon's gravatar image

accept rate: 0%

I have tried to look into this, but I can't see any explanation for the differing behaviour.

As far as I can see, all 3 suburbs are set up in exactly the same way on the OpenStreetmap side. Here are some direct links in case it helps anyone else: Dianella node

Dianella relation

Yokine node

Yokine relation

I don't know why the search engine does not return both entries for Dianella and Bayswater, or if that is linked to the Wikidata problem.

(24 Oct '21, 11:07) alan_gr

Calistemon, a few paragraphs and links would really help the reader. I'm sorry but I cannot follow what does work and what not.

(25 Oct '21, 08:06) TZorn

Sorry, it was typed out in paragraphs but the formatting here did not seem to accept that. I try again:

Yokine, Western Australia has an example for a functioning map:,_Western_Australia

A search for Yokine, Western Australia on OSM ( gets two results, "Suburb" (, which is the "Node" and "Suburb boundary" (, which is the "Relation".

On Bayswater, Western Australia (,_Western_Australia) all attempts to add an OSM map have so far failed but an OSM search for Bayswater returns a number of results, being a name used for a number of entities so I will use Noranda, Western Australia (,_Western_Australia) as an example instead as it is more unique.

(25 Oct '21, 13:51) Calistemon

A search for Noranda, Western Australia ( returns just two results, one being a Railway station under construction, which we can ignore. the other is the "Suburb" (, which is the "Relation". The "Node" does not show up in a search but can be found in edit mode (

My questions are:

Why do theses eight City of Bayswater suburbs not show up the Node in an OSM search?

Why does the "Relation" for Yokine show up under "Suburb boundary" but the "Relation" for Noranda as "Suburb"?

Does this make it any clearer?

(25 Oct '21, 13:52) Calistemon

Thanks, that is clear.

Can you give any more details of how OSM maps are inserted into Wikipedia (bearing in mind that many people reading this won't be Wikipedia contributors). At first glance it seems like there might be a basic instability where multiple objects in OMS have the same wikidata identifier. But maybe there is some rule e.g. to prioritise relations over ways over nodes.

(25 Oct '21, 20:17) alan_gr

The process on Wikipedia is quite simple once the Wikidata link on OSM has been made. From past experience, it only takes about 12-24 hours for OSM to update before the changes on Wikipedia can be made:

You remove: | alternative_location_map = Australia Western Australia metropolitan Perth"

You add: | map_type = nomap | local_map = yes | zoom = 11

This has worked really well for close to 450 Western Australia-related articles, just not for the below City of Bayswater ones:

Bayswater, Western Australia

Bedford, Western Australia

Dianella, Western Australia

Embleton, Western Australia

Maylands, Western Australia

Morley, Western Australia

Mount Lawley, Western Australia

Noranda, Western Australia

(26 Oct '21, 02:11) Calistemon
showing 5 of 6 show 1 more comments

I have no idea why Wikipedia shows one map but not the other.

edit: Since you only entered the wikidata ID to the Yokine relation 10 days ago it might be that the underlying Wikipedia database just hasn't picked up the change yet.

As to the search results: It appears Nominatim has joined both relation and node for Noranda (link), thus only showing one search result for both, but kept them seperate for Yokine (link 1, link 2). Maybe Nominatim hasn't recognized the quite recent addition of Wikidata tag in its joining yet? I can only guess here.

I would surmise that the odd Nominatim behavior has nothing to do with the Wikipedia map problem. But who knows.

permanent link

answered 25 Oct '21, 19:52

TZorn's gravatar image

accept rate: 15%

edited 25 Oct '21, 19:56

The map on the Yokine article works fine, as do close to 450 other Western Australia-related ones I added in the last few month. It generally only takes 12-24 hours for an OSM update to come through. The eight Bayswater ones were made over 2 month ago so I don't think its an updating problem anymore.

(26 Oct '21, 02:14) Calistemon

Looking more closely at the wikidata page, I see there is an "OpenStreetMap relation id". So Wikipedia should know exactly which OSM object to display. To find out why it is failing in some cases, you would probably need Wikipedia technical help rather than OSM help.

It is hard to see how this could be connected to the Nominatim search engine on OSM - why would Wikipedia need to search for the object when it is already identified in wikidata? I suppose it is possible, but again, it is really Wikipedia technical help that is needed to understand how this map tool relates to OSM data.

(26 Oct '21, 09:49) alan_gr

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 24 Oct '21, 08:31

question was seen: 1,200 times

last updated: 26 Oct '21, 09:49

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum