For the first time I decided to contribute to OSM by adding newly built road geometry.

Mostly this is Germany, Oberreichenbach, Würzbach, road name Kiefernweg. Geometry was added through browser base on a GPS mapping last sunday (more than 3 days ago).

These are the tree contributions I provided:

contribution 1

contrib 2

contrib 3

However when I open OSM in the browser - any browser, also on a different computer - the newly added geometry is only partially displayed, depending on map scale. This is how it looks like:

only partial geometry shown

Nevertheless in the browser edit page it all looks fine. Routing services based on OSM show the same issues and seem not yet including the connectivity through the newly added links.

This is how it is supposed to look like in a different map scale in OSM: different scale shows full geometry

To me it looks like the OSM tile update might not have worked, but I am not sure. Did I make a mistake? How to fix that, please?

Help would be appreciated, thanks!

asked 12 Aug, 10:15

MK0815's gravatar image

MK0815
1112
accept rate: 0%

edited 12 Aug, 10:26


Hi MK0815,

welcome to OpenStreetMap and thanks for contributing!

On my side the new road is shown properly on all zoom levels. As you suspected it is probably a matter of some cache on the way to your browser still serving the old tiles. It will be solved over time. In the meantime you can try to reload the page without using the cache (possibly Ctrl+F5).

The OSRM router on openstreetmap.org is also using the new road. Graphhopper probably still needs a day or two to also pick up the changes.

No need to worry.

On a side node: At least in Germany it seems to be consensus that the lanes= key should only be set if there are explicit lane markings on the ground or lanes are very obvious from other aspects. In a residential street with maxspeed 30 this seems to be unlikely to me. You might want to consider removing the lanes= key altogether and tagging a width instead but of course you will have local knowledge I don't.

permanent link

answered 12 Aug, 10:50

TZorn's gravatar image

TZorn
11.1k554204
accept rate: 15%

edited 12 Aug, 10:51

Hi TZorn,

thanks for your welcome and as well for providing the answer. And yes, this helped, I now as well can actually see the changes to be available :-)

(13 Aug, 21:55) MK0815
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×270
×215
×55
×32

question asked: 12 Aug, 10:15

question was seen: 208 times

last updated: 13 Aug, 22:25

powered by OSQA