can one explain why here https://www.openstreetmap.org/directions?engine=fossgis_osrm_foot&route=57.32642%2C-2.83276%3B57.32609%2C-2.83762#map=16/57.3284/-2.8349 not the short direct route on the red-dotted footpath is used? I added this path two days ago (I'm relatively new to OSM).

I also read this suggested post https://help.openstreetmap.org/questions/7015/tagging-public-footpaths-for-routing and tried to find out which data is used by the "Foot (OSRM)" and "Foot (GraphHopper)" route planners. From what I understood the planners don't necessarily know the current state of OSM, but I did not find an easy way to determine which version of OSM data is used in these route planners. Where can I see this?

Thank you & Best regards

asked 05 May '21, 11:34

BlaMa's gravatar image

accept rate: 0%

OSRM on www.openstreetmap.org does not find any route anywhere currently. There seems to be some general problem with the engine not with your path.

(06 May '21, 15:04) TZorn

For OSRM, it should be daily updates, for the FOSSGIS sponsored routing server. You can even find timestamps on this page.

permanent link

answered 05 May '21, 12:11

H_mlet's gravatar image

accept rate: 13%


Hi @H_mlet,

thank you, I can see the date in http://map.project-osrm.org/timestamps/footeuasi.data_timestamp It's more than two days since the last update (2021-05-03T08:00:00Z ) and this explains my issue. Also, GraphHopper is now using my foot path for foot only, which is what I wanted. I wasn't sure my edit was correct, but now I am.

(05 May '21, 13:00) BlaMa

There have been a few hiccups with the FOSSGIS OSRM server over recent days which the server admin is working to sort out, I believe.

(06 May '21, 19:25) Richard ♦

Answering @andy-mackey 's questions: It's working for me using GraphHopper now (see my answer to @H_mlet). When I made the post, OSRM just did not use my path, but worked in general. I use the openstreetmap in-browser editor to edit and added foot=yes, see this picture: alt text

permanent link

answered 06 May '21, 18:51

BlaMa's gravatar image

accept rate: 0%

Thanks everyone. Andy

(06 May '21, 23:45) andy mackey

What you see there under Allowed Access are implicit access rules, iD assumes. Maybe it uses the access defaults tor that, but I am not sure. Notice that the values are shown in a light grey.

The actual tags that you mapped are the ones on the bottom. In your case there are only highway=path, surface=grass and width=1. So you have actually not added foot=yes. Only when you actively change the values under Allowed Access do they turn black and get listed in the bottom Tags list and subsequently uploaded to the database. Check the info page of that way.

By the way: OSRM is working again and routing via that way (even without any access tags set).

(07 May '21, 09:18) TZorn

Thanks TZorn fro spotting that.

(07 May '21, 19:30) andy mackey

alt text

I think path needs an additional tag such as allowed or designated. The router doesn't route on private path or track. Check with local government somehow for status. Best to do a survey or walk it and read the official signage and use your GPS trace a camera, dicta phone or notes when surveying for later mapping a path or track.

permanent link

answered 06 May '21, 14:18

andy%20mackey's gravatar image

andy mackey
accept rate: 4%

edited 06 May '21, 14:22


I don't agree.

If no access tags for a path are given the router should either default to access=yes at least for non-motorized traffic or use the proposed default rules. I'd say paths mapped without access tags are pretty common.

(06 May '21, 14:48) TZorn

You may be correct, Scotland has a right to roam. Which would suggest you can walk anywhere (almost). # In the UK I have found the routers that didn't work for me did after i added designated or allowed to the paths but i was never quite sure because updating OSM used to have a bigger delay on OSRM and Graphhopper. Confirmation from other mappers and users of footpaths well be useful.

(06 May '21, 15:26) andy mackey

All the routers I've used default to foot=yes on paths without access tags...

(06 May '21, 15:52) H_mlet

Thanks TZorn and H_mlet. Ways i mapped with P2 as foot or bridleway didn't automatically get a foot=yes tag I have just add one here. and it should work soon. https://www.openstreetmap.org/directions?engine=graphhopper_foot&route=52.34107%2C-0.34661%3B52.33250%2C-0.34756#map=15/52.3357/-0.3401

(06 May '21, 16:12) andy mackey

If you look under the advanced tag on BlaMa's path it doesn't have foot=yes . I guess foot=yes needs adding as well. Potlatch doesn't add automatically if you select footpath i haven't check if JOSM and iD do. The path shows on the map BUT may not route without foot=yes being added. Feed back welcomed.

(06 May '21, 16:31) andy mackey

I couldn't see what editor had been used by BlaMa, i have forgotten how to get that info.

(06 May '21, 16:33) andy mackey

Hi all, thanks for chiming in. I'll add a comment with picture to the main thread. It's working for me using GraphHopper now (see my answer to @H_mlet). When I made the post, OSRM just did not use my path, but worked in general. I use the openstreetmap in-browser editor to edit.

(06 May '21, 18:46) BlaMa

Andy, what H_mlet and I are trying to say is that BlaMa does NOT need to ad a foot=yes to the path. Any decent router will assume that there is foot access to a highway=path if it is not explicitly forbidden.

As I commented on the question: Currently, I cannot calculate any route with OSRM anywhere. So unless it's different for you it's a bit futile to try/guess around now why it does not route over this one path.

(06 May '21, 18:57) TZorn

If no access tags for a path are given the router should either default to access=yes at least for non-motorized traffic

In reality, that's a very foolhardy assumption for bikes. Many mappers use highway=path for paths without any right of access for bikes.

(06 May '21, 19:25) Richard ♦
showing 5 of 9 show 4 more comments

Routing servers don't update as fast as Mapnik tile server. I guess it's because updating vector DB is more cumbersome than raster one.

If you are in a hurry, try telegram bot @RoutinoBot In a few secs, it will update routing around geocoordinate you'll attach (area approx 2 square mile)

permanent link

answered 10 May '21, 09:02

Cascafico's gravatar image

accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 05 May '21, 11:34

question was seen: 736 times

last updated: 10 May '21, 09:02

powered by OSQA