I edit a footpath or add a bench, etc. to a trail or just fix the name of a trail, or add a bridge or ford where needed over a stream. Then I save my changes and they are pretty much immediately viewable on the OSM. But when I draw a new path using an uploaded gps trace, when I save it, I do not find it on the OSM. I have waited a few hours or longer and it is not there. There were no errors or messages when saving so it all seemed to work.

Does anyone know, maybe it takes a lot longer, (days, weeks?), for a new path to show on the map than it does for edits to an existing path?

asked 09 Dec '20, 04:31

Will_T's gravatar image

Will_T
2613
accept rate: 0%

1

Hi, If you could give the changeset number someone could look to see if there's a problem with the edit.

(09 Dec '20, 14:42) BCNorwich

Below is the changeset number for the try the original trace maker did. I had given him instructions for making a trail/footpath from his original trace by manually drawing the trace on to the map. I don't see in his results though what I would expect.

Interestingly, in my own changeset history from yesterday, there is no record of me drawing a new line on the map even though I myself also went through the process and saved it. I did do a minor realignment to the short unmaintained track road that is at the start of his trace, then undid that test. Those edits shows up in my changeset history perfectly but there is no record of the new path I drew from his trace yesterday. When I saved that new path, there was no indication that anything was wrong, no errors or anything. The only odd thing I noticed is that after saving, there was not the normal small delay before going back to the edit screen. That clued me that maybe the saving of the edit was not completing but as noted, there was no message or anything that told me that.

In the past when I drew a new line using a trace to guide me, then saved it as a footpath, I think the new trail shows up on OSM with name and everything I did. Recently though I have not been drawing new trails so it has been a year or two since I put a totally new path on OSM and may not be remembering the process and how it worked correctly. My recent work has been on a trail system that was not on OSM, but that someone I talked to uploaded to OSM from Strava heat map data and a PDF map. So even though I am editing much of that data to make it more accurate to what is actually on the ground, I have not had to make any new trails from any of my recent traces.

Anyway thanks for your help and here is the changeset number from yesterday for the new trail the trace maker tried to draw. I am also attaching a screenshot of what I see when I look at the map with traces layer enabled where his new trail from this changeset, and my unsuccessfully saved trail should be. alt text

Changeset: 95517279

(09 Dec '20, 17:31) Will_T

For completeness, https://forum.openstreetmap.org/viewtopic.php?pid=811073#p811073 seems to be a cross-post.

(09 Dec '20, 20:24) SomeoneElse ♦

Hi Will.

No, there is no different handling of new paths and other objects. If the new path is not showing up it might be an issue with caching of old tiles either in your browser or on some upstream server. This could happen with all kinds of objects. You can try to force a re-load in your browser (often Ctrl + F5) or wait some more time. It could also be you made some mistake in the tagging of the path preventing it from being displayed. If you send us the link or ID of the path we can take a look.

And by the way: Thanks for making all these nice additions. I try to extend hiking infrastructure myself and there are still so many gaps to close.

permanent link

answered 09 Dec '20, 08:34

TZorn's gravatar image

TZorn
8.8k443168
accept rate: 14%

I figured out the issue and indeed it was me. I had forgotten that in the default editor at least, you need to double click on the end of your line drawing for it to attach itself to the map. Then all works as it should. I feel so dumb that I did not remember that detail. Oh the frustrations of a very old brain! Sorry to waste anyone's time.

permanent link

answered 09 Dec '20, 21:41

Will_T's gravatar image

Will_T
2613
accept rate: 0%

Glad you found the solution. Indeed it seems a line has to be finished drawing before it can be uploaded.

(09 Dec '20, 22:10) TZorn

Yeah, finished as in that all important 2nd click on the last node. Can't believe I forgot about that. Otherwise when if you just hit the Control-S shortcut, it goes through the process of looking like it is saving your line, including allowing a comment and tags. But when you then tell it to Upload, it just goes back to your starting map. No error message or anything.

(10 Dec '20, 00:10) Will_T

OK there's nothing wrong with the data uploaded to OSM, just two changesets in the last 30 days as shown here :-https://tyrasd.github.io/latest-changes/#14/42.7823/-73.3047 The extended track along the GPS trace just wasn't uploaded, probably just a passing Gremlin. Try again!

permanent link

answered 09 Dec '20, 18:10

BCNorwich's gravatar image

BCNorwich
4.7k53468
accept rate: 20%

Well, I think I am just not remembering the correct way to do this or something as it has been a couple of years since I added any completely new trails to OSM. I just tried on a different area of the map and had the same result. Here is what I am doing. Maybe you can see the error of my way?

I went to an uploaded trace and clicked the "edit" button to the right of the trace name. A new tab with the trace shown over the OSM edit map is opened. I then used the line tool to manually point and click along the trace to manually draw a line. Then clicked the save button in the top right. The save dialog opens and I put in a comment explaining the work. Then clicked the "upload" button. The screen then just immediately returns to the previous editing map as if I had made no changes at all. It is not saved and when returned to the map the line I drew is cleared. I tried twice with the same result. The 2nd time I also added the tag highway=path but that made no difference.

Where am I going wrong? I don't recall any such trouble way back when I previously added a new path.

(09 Dec '20, 20:27) Will_T

I tried it exactly in the way you described and I successfully created the new way 882964960. I have no clue what went wrong with your edit. Maybe try it in another browser. Or use the external editor JOSM.

(09 Dec '20, 20:59) TZorn

I also just accessed the map from the uploaded traces page by clicking "map" rather than "edit". Then I enabled the layers tick box for OSM GPS traces so could see all the traces for the area. Then manually drew a line with the line tool. Clicked save and then upload and got the same result. Just went back to the previous screen with no evidence of the new line/path. Also no new changeset so it really is not being saved. Just surprised to get no error message explaining why.

(09 Dec '20, 21:00) Will_T

Wow! I am using Edge, but just tried in Chrome with same result. Both of us are using the default online editor iD. That is the only editor I have ever used. Potlatch wants flash which I no longer have. And JOSM I have not taken the time to learn anything about. I have always been fine with the default browser. What makes me think I am doing something in the process wrong, is that any other type of edit other than a new line works fine. On the one of the places on the map that I am trying to draw new trails, there is a closeby already existing trail. I just did a minor edit to that trail and saved and all worked fine. Change shows up and there is a changeset. So for some reason how I am doing the new trails is wrong. I don't think it is the browser or editor, I think it is me!

(09 Dec '20, 21:16) Will_T
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×84

question asked: 09 Dec '20, 04:31

question was seen: 232 times

last updated: 10 Dec '20, 00:10

powered by OSQA