I have moved to a new Microsoft Windows 10 PC. This has a new installation of Firefox 68.12.0esr (64-bit) and Flash Player (32,0,0,433) but uses a copy of the profile I had on the old PC. I have Privacy Badger, HTTPS Everywhere, and NoScript installed.

When I try to use Potlatch2 to edit, it starts as normal. On the left, there is the standard list of icons. At the top right there is the usual row of buttons. However, the main screen stays blue (when I would expect this to show both the map data and background imagery). The Background button has an empty list with Dim, Sharpen, and Show Floating Window tick boxes plus Edit.. and Vector File... buttons. Map Style has an empty list with an Edit button.

I've seen something similar before when an addon was blocking access to some domain or other. I have tried disabling the addons, and even starting Firefox in Safe Mode. In the Extensions menu, I have unticked "Block dangerous and intrusive Flash content". I have also tried a new Firefox profile. None of this helps.

Potlatch 2 still works in Firefox on my old PC, and it works on the new PC if I use it in Microsoft Edge (the new type that uses Chromium and with Flash 32,0,0,433).

Any suggestions?

asked 12 Sep, 21:09

jpennycook's gravatar image

jpennycook
564412
accept rate: 0%

closed 17 Sep, 21:50

SimonPoole's gravatar image

SimonPoole ♦
41.0k13300649

https://wiki.openstreetmap.org/wiki/Potlatch_2 i had enable flash on a win PC with Google.

(13 Sep, 06:46) andy mackey

If Flash is disabled, you don't get to see anything I described in the second paragraph. Flash is working.

(13 Sep, 09:59) jpennycook
1

I've also noticed problems with flash in Firefox on Windows 10 - not that it doesn't load, but that it occasionally hangs the browser. Flash in Firefox on Linux (KDE) has no problems, and Flash in Chromium-based browsers such as Chrome or Chromium on Windows 10 also has no problems.

(13 Sep, 10:14) SomeoneElse ♦
1

I've had this and in general as SomeoneElse suggests this appears to be something related to Flash. It's appears sporadically. In general I've just used an alternative editor when this has occurred. Something else I've had a fair bit of is Flash losing focus so that keyboard shortcuts dont work (and typing changeset comments or tags fails too). Switching away to another application and back again usually sorts it. It seems to happen a lot with tasks.

(13 Sep, 22:47) SK53 ♦

Thanks. I think the answer is to switch to using a Chromium-based browser (I've got three on the new PC), or continue using Firefox on the old PC (or on my laptop).

(15 Sep, 08:29) jpennycook
1

It might be interesting to look in the developer console to see if there are any errors relating to content that P2 can't load.

(15 Sep, 14:53) Richard ♦
2

I decided to replace my Windows profile because it was giving me other problems - and now I can use Potlatch again! I actually created a new profile then copied in (most of) my existing files, so it looks the same. I didn't see any problems when I tried the Developer Console the other day.

I think we'll put this down to not migrating the profiles properly between the two PCs.

(17 Sep, 08:41) jpennycook
showing 5 of 7 show 2 more comments

The question has been closed for the following reason "Other" by SimonPoole 17 Sep, 21:50

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×208
×65
×20
×14

question asked: 12 Sep, 21:09

question was seen: 109 times

last updated: 17 Sep, 21:50

powered by OSQA