Since a few days the right-hand side menu items with 'layers', 'query features' etc no longer respond. This is Safari

asked 10 Sep, 00:01

Joris%20Wu's gravatar image

Joris Wu
262
accept rate: 0%

edited 10 Sep, 02:34

nevw's gravatar image

nevw
8.8k2585156

I can confirm same here on OpenStreetMap.org using Safari on imac Catalina 10.15.6 for layers, map key, share and query features items but my iphone 6 safari is working fine. Other browsers fine.

(10 Sep, 00:15) nevw

No problem with Win 10 PC

(10 Sep, 00:46) andy mackey

Issue resolution is in progress on Github https://github.com/openstreetmap/openstreetmap-website/issues/2811

permanent link

answered 10 Sep, 04:04

nevw's gravatar image

nevw
8.8k2585156
accept rate: 10%

I also have this problem all the time. Is the resolution about to be released ? This is very annoying. Thanks.

(13 Sep, 21:30) Martin Chali...
2

It's a bug in Leaflet, the map display library that OSM uses. It can't be fixed in OSM until the Leaflet maintainers commit a fix. You can follow progress at https://github.com/Leaflet/Leaflet/issues/7255 .

(15 Sep, 14:56) Richard ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×76

question asked: 10 Sep, 00:01

question was seen: 130 times

last updated: 15 Sep, 14:56

powered by OSQA