If I select an item (e.g. a "highway=residential" with no other tags yet) in JOSM, the item appears in the "Selection" panel at the right-hand side.

Unfortunately, however, it's displayed as "highway (2 nodes)" not as "way 125419318". Is it possible to make the selection list always should the item ID? Obviously, I can select the item and "inspect" it but that's a lot of clumsy messing around with the mouse and a popup window. Similarly ctrl-i and ctrl-h work to open browser pages for the item, but I suspect that there's a setting somewhere to make IDs appear in the main list.

asked 04 Sep '11, 14:48

SomeoneElse's gravatar image

SomeoneElse ♦
32.3k63335756
accept rate: 15%

edited 05 Sep '11, 16:00

dieterdreist's gravatar image

dieterdreist
3.6k113466


Add the line

osm-primitives.showid=true

to your JOSM preferences file.

permanent link

answered 04 Sep '11, 16:55

Frederik%20Ramm's gravatar image

Frederik Ramm ♦
71.3k846451113
accept rate: 24%

1

Thanks - I actually got to it via Edit / Preferences / Display / Look and Feel / Show Object ID in selection lists

(04 Sep '11, 17:27) SomeoneElse ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×521
×23
×2

question asked: 04 Sep '11, 14:48

question was seen: 5,580 times

last updated: 05 Sep '11, 16:00

powered by OSQA