when driving north to east (top to bottom) the gps switches from "driving on Main North Road" to "Driving on Trail" at this intersection, I tried to fix it the other day but went overboard and deleted the crossing, I feel that was a little over board and someone kindly reverted my edit... so now i'm back to square 1, can anybody help me please? https://www.openstreetmap.org/edit#map=19/-34.78336/138.65430

asked 02 Apr, 05:47

slice0's gravatar image

slice0
11123
accept rate: 0%

edited 02 Apr, 15:32

scai's gravatar image

scai ♦
32.0k20293443

3

It's unclear what your issue is exactly. Are you complaining that you get sent the wrong way? Do you get confusing voice instructions? Something else?

What route are you talking of exactly? You could use the router on www.openstreetmap.org (road sign arrows button on the top left) and link to the result.

(02 Apr, 07:51) TZorn

it's not while routing, just normal driving. the GPS says "driving on Main North Road" then switches to "driving on Trail" at this intersection

(02 Apr, 08:21) slice0
2

Please tell us which device and app/software you are using.

(02 Apr, 09:00) scai ♦

Garmin Nuvi 1450, map is from both openmapchest and garmin.openstreetmap.nl, both maps have same result

(02 Apr, 15:18) slice0

There's absolutely no difference in tagging of Main North Road between north and south side of this intersection. Did you notice any graphical difference on the display ?

I could not find any close path that could mistakenly used by the gps unit.

Or does it happen only during the crossing of the intersection ? In this case it could be that the gps thinks it follows the footway ?

(02 Apr, 16:39) H_mlet

the other person posted this https://www.openstreetmap.org/#map=18/-34.77479/138.66189 it does look really messed up

(02 Apr, 16:43) slice0

since nuvi device is very different from other garmin device you must follow the steps for updates as instructed.garmin nuvi 1300 update . for your 1450, the method will be same as 1300 nuvi

(24 Oct, 10:29) james lane
showing 5 of 7 show 2 more comments

Hi Slice0. As has been pointed out by others there does not seem to be much wrong with the tagging. It probably comes down to your gps not identifying the road correctly you are on or messing up something else.

But I want to point out one important other thing. While figuring out what was going on you started deleting mapped paths that you found offending (eg). These parts were rightfully mapped and were probably valuable information for other users. Just because you think your GPS gets confused doesn't mean you should just delete them. Another user has kindly reverted these changes already so no lasting harm done but please be careful in the future before making such changes. It has been a good idea coming here for help.

permanent link

answered 03 Apr, 07:55

TZorn's gravatar image

TZorn
6.9k333135
accept rate: 16%

The best solution for this issue is that you download Garmin express from garmin.com/express. It seems like this is a software glitch. I think we are going into technicalities, but sometimes solutions can be straightforward as just updating the software. I can't be sure if it is going to work. However, last year, I was facing this issue, so I updated it with the latest Garmin express 5.9.0. now there will be a new version available. It's worth trying. If you have deleted the crossing, that's completely fine. That the missing file will not be there, I think it is gmapprom.img file. It's not going to be there. If you want to get that file, you can contact Garmin to get some support. I accidentally deleted my Garmin drive 65s maps and tried to restore them. So I contacted official Garmin, and they had a long wait. So I went to the visit Garmin express updater site, and they helped me and restored my GPS maps. I lost poi's, but I can save them in the future. I think the mentioned site it is some third party site. But it was for free, so who cares.

permanent link

answered 17 Aug, 20:52

shawn%20diwas's gravatar image

shawn diwas
241
accept rate: 0%

I have tried GraphHopper and OSRM ( car mode) they are the two routing systems available on the map page and they both seem to work correctly to me. I suspect the mapping data on your GPS device is incorrect, can you install an update? The data on your device may not get updated to what is on OSMs database that quickly. This is what one router does when routing through your linked point. https://www.openstreetmap.org/directions?engine=graphhopper_car&route=-34.7610%2C138.6742%3B-34.7982%2C138.6416#map=13/-34.7778/138.6811 From your comment below changing OSM data won't fix your device's routing until that device has that new data installed, be aware that there is always a delay in updates being used in the map data incorporated into data assembled for an update. So what is the device, the app and does the device use OSM data, and if so how old is the data? and where did/will you download it from.

permanent link

answered 02 Apr, 14:29

andy%20mackey's gravatar image

andy mackey
12.3k77132269
accept rate: 4%

edited 02 Apr, 21:57

1

I suspect a faulty edit here, I'm guessing the road does not look like this. Probably needs reverting. https://www.openstreetmap.org/#map=18/-34.77479/138.66189

(02 Apr, 14:51) andy mackey

routing is perfectly fine, it is just when the gps is just on and telling me where I am and which road I am driving on is when I notice it. the road does not look like that!, that might be the problem

(02 Apr, 15:10) slice0

The OSM map that is on your 1450 device may have the error is there a more recent download available. The Two OSM ones you have probably have the same error which HAS been fixed now. So try a new download(s).

(18 Aug, 11:14) andy mackey
-1

hi there, i believe that if a GPS switches without any notification, then maybe a software update can do wonders. as pointed by shawn in the comment above. However, garmin express can only fix software map related issues, what if your GPS has some hardware issue. if voice is your concern download the latest voices too. for more you must visit garmin.com/express.

permanent link

answered 24 Oct, 10:23

james%20lane's gravatar image

james lane
(suspended)
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×298
×29
×9
×2

question asked: 02 Apr, 05:47

question was seen: 601 times

last updated: 24 Oct, 10:29

powered by OSQA