NOTICE: is being shutdown on 1st March 2024. Please use the OpenStreetMap Community Forum

I just got a Garmin eTrex 30x and I installed a freshly-formatted microSD card (8GB, SanDisk) into it, and then plugged it into my MacBook Pro (macOS 10.15.2) and let Garmin Express update the TopoActive maps (Europe 2019.20). It seemed to detect the microSD card fine and decided to change the install location of the TopoActive maps from the internal memory to the microSD card, and downloaded a significantly larger update than it was going to when I didn't have a microSD card installed (6-something GB vs 3.7 GB).

Well now my eTrex 30x doesn't show any maps besides the BaseMap and a "Garmin DEM Map ED 2017.20"! It's like it isn't reading the microSD card at all!

I've also tried putting the British Isles version of the OpenTopoMap on the microSD card and that doesn't show up either.

So what do I do now that the stupid Garmin Express software has deleted the TopoActive maps from the device memory and installed a huge version on the microSD card which the device doesn't seem to want to read?

asked 21 Feb '20, 03:58

Brenden's gravatar image

accept rate: 0%

This question may be of help, let us know what does or doesn't work. Please give us a spet by step of the map you tried and a link to it.

(21 Feb '20, 16:53) andy mackey

Thanks for your comment and pointing me to that thread.

I downloaded the OpenTopoMap for British Isles from and put it on the microSD card in a root folder called "Garmin", then inserted the microSD card into the device. The map did not show up in the enable/disable maps option screen.

I also plugged the device into my MacBook Pro and used Garmin Express to update the TopoActive maps that were already installed to version 2019.20. It said they were too large for the internal memory and so would go on the microSD card, which they did. However, after 3 hours of Garmin Express writing them to the microSD card via the device, on turning on the device the maps were nowhere to be seen and the only maps available for enabling/disabling were now the "Worldwide DEM Basemap" and "Garmin DEM Map EU 2017.20". So the Garmin Express software basically deleted the original TopoActive map and Worldwide full Basemap that was on the device and replaced them with demo versions.

Anyway, I just purchased a new microSD card which will arrive this evening and I will be trying it out to see if the issue was with the card.

(21 Feb '20, 17:38) Brenden

I download an OSM on garmin file of the country i need, unzip it, then transfer it into a Garmin or Map ( depending on device) folder that i have created in the micro SD card and it usually works. Some older devices will only display a map called Gmapsupp but the etrex 30x can use sensible names. see

permanent link

answered 22 Feb '20, 19:50

andy%20mackey's gravatar image

andy mackey
accept rate: 4%

edited 22 Feb '20, 19:53

I purchased a new microSD card (also SanDisk, but 32 GB) and installed it and it works! So it seems the issue was something to do with the microSD card I was using — even though it was working perfectly fine through the USB cable, the device itself wasn't recognising it.

permanent link

answered 22 Feb '20, 21:26

Brenden's gravatar image

accept rate: 0%

I am pleased you have got the map to work, and thanks for letting us know.

(23 Feb '20, 07:50) andy mackey
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 21 Feb '20, 03:58

question was seen: 3,542 times

last updated: 23 Feb '20, 07:50

NOTICE: is being shutdown on 1st March 2024. Please use the OpenStreetMap Community Forum