Map loading on the web stops working, shows only gray area, see n image. Thank you in advance for your help ...

alt text

asked 10 Feb, 10:04

Du%C5%A1an's gravatar image

Dušan
11112
accept rate: 0%

2

Can you provide a bit more information? What you have said so far is a bit like saying to someone "my car doesn't start" and attaching a photograph from 100m away...

(10 Feb, 10:18) SomeoneElse ♦

Hi, I have noticed that when I access the page from another source (another ip address) the map loads fine. Is it possible that my ip address is blocked?

Thank you in advance for your help...

(10 Feb, 11:52) Dušan
1

You should check in the browser console the URL you're using for tiles, and the status response you get.

It's possible to get blocked for heavy usage, both by IP and User Agent headers.

Please check that you're adhering to the Tile Usage Policy.

(10 Feb, 12:14) H_mlet

I have the same issue in some prod websites.

At the moment, we use HTTP Protocol. If I try to reach tiles osm server “http://a.tile.osm.org/xx/xxxxx/xxxxx.png” , then I get a "Server not found" error.

Should I change the library in order to use HTTPs?

permanent link

answered 10 Feb, 10:56

jasa_'s gravatar image

jasa_
111
accept rate: 0%

1

Using tile.osm.org URLs on a production machine is a bad idea as there's no guarantee of uptime. See here for more details.

Notwithstanding that:

  • OSM tileserver URLs have been https-only for some time now. Depending on how you use them, redirection may not occur.

  • you're using a shortened version of the URL. A valid tile is https://tile.openstreetmap.org/9/253/166.png - try fixing your links to use that and see if it fixes your problem.

(10 Feb, 11:04) SomeoneElse ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×455
×21
×3

question asked: 10 Feb, 10:04

question was seen: 342 times

last updated: 10 Feb, 13:02

powered by OSQA