I used to use Maps.me Android app to add house numbers. About a week ago the "Edit Place" button disappeared. I can still add and edit bookmarks.

I've tried: restarting the app, re-logging to OSM and clearing cache.

asked 30 Jan, 19:08

aneleutheroi's gravatar image

aneleutheroi
1911510
accept rate: 100%


I got a quick response:

"The Edit Place button automatically disappears if the downloaded maps are older than two months. Usually we update maps before before the deadline, but, sometimes, a new update may be postponed.

It takes time to convert OpenStreetMap (the whole planet) to our data format. Plus, it requires time for testing as every release of the app contains new features and improvements and it requires to check if everything works with a new data. We postponed the new update as we require more time to fix all issues that we found during testing. We plan to release it, approximately, in the beginning of February."

Problem solved!

permanent link

answered 31 Jan, 06:18

aneleutheroi's gravatar image

aneleutheroi
1911510
accept rate: 100%

2

In the interim, if you have a mobile data plan, there are some OSM editors that run on Android. Vespucci is probably the most powerful (with a steep learning curve) and StreetComplete the friendliest for new users.

Offline navigation app OsmAnd also has some editing capability (and can store edits until you reach WiFi). But it doesn't extend this ability to buildings without further tags.

(31 Jan, 08:46) InsertUser
1

Vespucci works fine as a download, edit and upload without mobile data. Indeed for some countries you can download substantial areas for on-the-go editing

(31 Jan, 21:08) SK53 ♦

Since you are in touch with them, could you suggest them adding the original date of the data somewhere in the app ?

When I download maps, I don't expect them to be months old...

Thanks for sharing the answer anyway.

(01 Feb, 21:14) H_mlet
1

I find Vespucci very cranky and slow (and hard to exit!), but might give it another go.

As for data version, it's buried in the app under "About MAPS.ME" - current one is "191124" (Nov last year).

(01 Feb, 21:42) aneleutheroi

I can still add new places, after long clicking on an empty spot. But I can't modify them either. I can review the POIs or claim them as my own (for ads it seems). Maybe that's the new policy.

The docs say that up to date maps are needed to modify, but I can't update them.

You could try to write to them directly.

permanent link

answered 31 Jan, 02:12

H_mlet's gravatar image

H_mlet
1.6k730
accept rate: 14%

Ah, good to know I'm not the only one. They don't have an obvious "contact us" place, but I've found an email address on Google Play: android@maps.me, which I'll use.

(31 Jan, 05:01) aneleutheroi
1

Naturally adding new things based on a long out of date map is just as bad as modifying them, just because maps.me allows one over the other doesn't make it a good idea.

(31 Jan, 18:56) SimonPoole ♦

Well, I guess it's easier to spot and revert so I wouldn't say it's as bad...

But the whole point of editing stored data is tricky (at best). Personally I just take notes if offline, and process them when online, using Vespucci or JOSM.

(01 Feb, 21:10) H_mlet
-1

Try changing the date and time of your device to 16 of January and restart Maps.me. The Edit Place button should be present.


Read other answers for the explanation why this solution works. Read comments and you'll probably not want to try this solution at all - you should not edit outdated maps.

permanent link

answered 09 Feb, 08:35

naXa's gravatar image

naXa
101
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×73
×13

question asked: 30 Jan, 19:08

question was seen: 392 times

last updated: 09 Feb, 08:35

powered by OSQA