I have a VPS with 6 core, 60GB RAM and 1TB SSD space.

I installed Nominatim on Ubuntu 18.04 following the official installation here Nominatim Installation

I tried to import the openstreet planet pbf file located here Planet OpenStreetMap using the command below:

./utils/setup.php --osm-file planet-latest.osm.pbf --all --osm2pgsql-cache 28000 2>&1 | tee setup.log

After few hours I got the error Segmentation fault ERROR: No Data see below:

> 2019-11-30 16:50:55 == Setup DB Postgres version found: 10 Postgis
> version found: 2.4  set_config
> ------------
> 
> (1 row)
> 
> 2019-11-30 16:51:04 == Import data osm2pgsql version 1.2.0 (64 bit id
> space)
> 
> Allocating memory for dense node cache Processing: Node(618450k
> 2425.3k/s) Way(0k 0.00k/s) Relation(0 0.00/s) Allocating memory for sparse node cache Sharing dense sparse Node-cache: cache=28000MB,
> maxblocks=448000*65536, allocation method=11 Mid: loading persistent
> node cache from /srv/nominatim/flatnode/flatnode.file Mid: pgsql,
> cache=28000 Setting up table: planet_osm_nodes Setting up table:
> planet_osm_ways Setting up table: planet_osm_rels Processing:
> Node(621390k 2427.3k/s) Way(0k 0.00k/s) Relation(0
> 0.00/s)import-full.style'. Using projection SRS 4326 (Latlong) NOTICE:  table "place" does not exist, skipping
> 
> Reading in file:
> /srv/nominatim/Nominatim-3.4.0/build/planet-latest.osm.pbf Using PBF
> parser. Processing: Node(5612922k 3148.0k/s) Way(437617k 33.05k/s)
> Relation(0 0.00/s)Segmentation fault ERROR: No Data string(7) "No
> Data"

Any idea why I got this error please? Thanks.

asked 01 Dec, 11:43

okamal's gravatar image

okamal
26
accept rate: 0%

What is the date of the planet file that you downloaded, 191118 or 191125? If you don't remember then what is the exact size (in bytes) of your planet-latest.pbf?

(01 Dec, 13:35) lonvia

I went to the Planet OpenStreetMap link above and downloaded the Latest Weekly Planet PBF File from this link https://planet.openstreetmap.org/pbf/planet-latest.osm.pbf. It is 45GB in size.

(01 Dec, 13:48) okamal

The newest planet is 48GB. So either you have a planet that is at least 2 months old or your download was incomplete. An incomplete pbf would also explain the segmentation fault.

(01 Dec, 15:32) lonvia

Sorry I meant 48G not 45GB. My terminal shows it : -rw-rw-r-- 1 nominatim nominatim 49G Nov 28 14:49 planet-latest.osm.pbf and the file is the newest one, downloaded yesterday.

(01 Dec, 15:48) okamal

I imported the same file with Nominatim 2.4, osm2pgsql 1.2.0 two days ago and it finished fine. "Node(5612922k 6921.0k/s) Way(622516k 96.77k/s) Relation(7236370 1012.79/s)", the node count matches your output so I think the planet file and osm2pgsql version itself is alright.

(01 Dec, 22:15) mtmail

Actually I changed this --osm2pgsql-cache 28000 to this --osm2pgsql-cache 18000 and it worked. It is still importing data since 12 hours now. I'll comment again if all worked fine. Thanks.

permanent link

answered 01 Dec, 22:23

okamal's gravatar image

okamal
26
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×558
×276

question asked: 01 Dec, 11:43

question was seen: 78 times

last updated: 02 Dec, 12:33

powered by OSQA