Hi all, I´ve just started using uMap for displaying my cycle routes on my blog. I have created 3 uMaps now and copied the embed code for each into 3 separate blocks on the page I want them displayed on. The first embed shows the mini-map, no problem. The second and third however, are blank...blank as in the frame is visible, but the contents of the frame, where the map should be displayed, is pure white space. This "feature" :) can be seen on my live route page here:

Site url: https://kvbcycles.com/route/

I´m running Wordpress 5.2.4 on the site. I´ve double checked the embed code - looks good to me. I´ve re-created the blocks too, with no success. I used to have the OSM plugin loaded into my WP site but that too did not work, very similar problem - on the admin side, when trying to create viewable maps, it was blank space...this however, could be totally unrelated.

Any questions, please ask, otherwise, open to suggestions.

Karl.

asked 26 Oct, 20:07

KvB%20Cycles's gravatar image

KvB Cycles
112
accept rate: 0%


I have no knowledge on Wordpress. But when I look a the code in the pages I see some differences.

What happens if you replace the uk-to-arrasate-2018_380939 in the working map with the arrasate-to-madrid_380941 from one of the non-working ones? Will it then display that map? If so copy and paste the code from the page with the working map to the non-working one and just replace the map name like this.

permanent link

answered 31 Oct, 08:50

TZorn's gravatar image

TZorn
3.4k21771
accept rate: 12%

Thanks for the response and suggestion. I´ve gone ahead and tried that but no dice. So, I copied the uk-to-arrasate code, pasted it into the arrasate-to-madrid block, updated the page and the map shows, but for uk-to-arrasate (so the wrong umap). I then edited the code, replacing uk-to-arrasate with arrasate-to-madrid and updated the page. Blank block again.

I also created separate pages for each, whereas when I first embedded all 3 were on 1 page. That also does not solve the problem. Wondering if there´s a limit to embed uMaps into a single WP site?

Karl.

(31 Oct, 22:53) KvB Cycles
1

Are you sure you copied the complete code? In UK to Arrasata the iframe link to uMap uses https: while for Arrasate to Madrid it is http:

(01 Nov, 11:09) TZorn

Joder! That´s all it was, a little "s" to make it "https"...thank you TZorn for giving it the once over and spotting that tiniest of anomolies :) Maps now showing up....

(07 Nov, 21:34) KvB Cycles
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×183
×54
×7
×6

question asked: 26 Oct, 20:07

question was seen: 189 times

last updated: 07 Nov, 21:34

powered by OSQA