Just installed OSM on Ubuntu 18.04 using the rather excellent guide published by the switch2osm folks.

Everything works up to and including the initial manual test of rendered.

When I try to go to the web page at http://yourserveripaddress/osm/0/0/0.png (yes, using the server's IP address) I get the following error;

The requested URL /osm/0/0/0.png was not found on this server

I've reviewed all of the steps and confess I am a bit confused, not that that is particularly unusual. I tend to get grumpy when I follow a recipe and I burn the cake... so to speak.

Any help would be most helpful.

asked 18 Sep '19, 07:24

amu306's gravatar image

accept rate: 0%

Which instructions did you follow exactly - these: https://switch2osm.org/manually-building-a-tile-server-18-04-lts/ ? In that case (slightly non-intuitively perhaps) your tiles will be under /hot/ not under /osm/.

In any case double-check that you have made the necessary changes to the Apache config as documented, and if things still don't work let us see what appears in your /var/log/apache2/error.log when you make this request.

permanent link

answered 18 Sep '19, 07:36

Frederik%20Ramm's gravatar image

Frederik Ramm ♦
accept rate: 23%

I followed https://www.linuxbabe.com/linux-server/openstreetmap-tile-server-ubuntu-16-04 this article to setup tile server on ubuntu 18.04 . All is set up perfectly but the image was not found

(18 Sep '19, 09:24) amu306

Are you sure you used this guide. Because up there you said that you followed a switch2osm guide which is different. And the guide you have just quoted says "Then in your web browser address bar, type your-server-ip/osm_tiles/0/0/0.png" - but you apparently expected that "/osm/0/0/0.png" works. Where did you get that from? It appears that you might have burnt your cake by using a random mix of recipes!

(18 Sep '19, 09:43) Frederik Ramm ♦

this is what can be seen while rendering sudo -u tharakk renderd -f -c /usr/local/etc/renderd.conf

renderd[31905]: Rendering daemon started renderd[31905]: Initiating reqyest_queue renderd[31905]: Parsing section renderd renderd[31905]: Parsing render section 0 renderd[31905]: Parsing section mapnik renderd[31905]: Parsing section default renderd[31905]: Parsing section style2 renderd[31905]: config renderd: unix socketname=/var/run/renderd/renderd.sock renderd[31905]: config renderd: num_threads=4 renderd[31905]: config renderd: num_slaves=0 renderd[31905]: config renderd: tile_dir=/var/lib/mod_tile renderd[31905]: config renderd: stats_file=/var/run/renderd/renderd.stats renderd[31905]: config mapnik: plugins_dir=/usr/local/lib/mapnik/input renderd[31905]: config mapnik: font_dir=/usr/share/fonts/truetype/ttf-dejavu renderd[31905]: config mapnik: font_dir_recurse=1 renderd[31905]: config renderd(0): Active renderd[31905]: config renderd(0): unix socketname=/var/run/renderd/renderd.sock renderd[31905]: config renderd(0): num_threads=4


(18 Sep '19, 13:18) amu306

Before you posted this you posted a link to your server IP which I will not repeat assuming you removed it on purpose. But that link proves that your mod_tile is working and that you have actually configured a /osm/ tile layer; however mod_tile immediately returns a 404 error for any tiles requested. Likely this is either because mod_tile cannot contact the renderd server - could be a freak local networking or security issue e.g. SELinux - or that mod_tile does contact the server but then gets an error message back. Check the /var/log/apache2/error.log for further info.

(18 Sep '19, 14:00) Frederik Ramm ♦

In my case, the 404 error occurred because the apache2 configuration was wrong. I put localhost in the apache2 settings. I checked /var/log/apache2/error.log for errors. When I changed localhost to IP, it worked fine.

permanent link

answered 20 Mar, 10:59

kharma77's gravatar image

accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 18 Sep '19, 07:24

question was seen: 3,534 times

last updated: 20 Mar, 10:59

powered by OSQA