NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I have just started using OSM for hiking tracks. The Directions panel is great for fast planning of tracks, but three times out of eight I have found the route is diverted around what looks like incomplete map data, like connections or permissions. I have edited the data, and would like to check if that fixes the problem, but the effects don't seem to be shown on the directions. I guess this is because OSRM has to wait for a graph update. Could there be a way of checking quicker? Like being able to see the local route graph for a class of transport? Or running the router on what is on screen?

asked 10 Jun '19, 11:09

arbuthnot's gravatar image

accept rate: 0%

The short answer is: no.

The long version: all routing engines have to update the data and the routing graph in some fashion and currently none of the server side engines does this incrementally (for technical reasons). So typically you will need to wait a day or so to see you changes there.

JOSM used to have a plugin that did this on freshly edited data, but no idea how well this worked/works. Outside of that you best bet is OSMand with a "live" subscription that will typically update in 1-2 hours.

permanent link

answered 10 Jun '19, 12:22

SimonPoole's gravatar image

SimonPoole ♦
accept rate: 18%

Simon mentioned the JOSM plugins, so I don't understand his categorical "no". I would rather say "yes, but". :-)

Instead of iD you can use the OSM Editor JOSM. For this editor there are two plugins available: GraphView and Routing. Both work with the OSM data currently loaded in the editor including all your changes you have made but not uploaded yet. The former plugin provides an overlay for a routing graph. It's a bit difficult to spot gaps with this tool, though. The latter plugin offers rudimentary routing and enables you to test your edits. It does not take into account access restrictions ("no bicycles here"), though. So it works to test if all roads are there and connected but not to test for the right permissions.

permanent link

answered 10 Jun '19, 14:51

TZorn's gravatar image

accept rate: 15%

Following up on your advice, I have installed JOSM, found the remote control option, and enabled it. I get Failed to initialize communication with the OSM server Check the server URL in your preferences and your internet connection.

I have also tried downloading a map into JOSM, and get the same message. I have searched for advice on this, followed recommendations about connection and proxy settings , and still get the same. Sorry for all the beginner problems.

(10 Jun '19, 16:38) arbuthnot

@TZorn: as said that was the short version.

(10 Jun '19, 17:53) SimonPoole ♦

@arbuthnot: Better start a new question for this issue.

(10 Jun '19, 20:30) TZorn

If you want to test routing for small areas you can use OSMAndMapCreator to generate OsmAnd file that can either be sideloaded onto a phone for testing or tested directly in the map creator software.

The MapCreator software is rather rough, so YMMV on testing without transferring to a mobile device.

permanent link

answered 10 Jun '19, 20:01

InsertUser's gravatar image

accept rate: 19%

I've just checked and the router will route along un-uploaded ways in a JOSM file, so it may be possible to test reasonably complex edits before making them 'live'.

(10 Jun '19, 20:18) InsertUser

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 10 Jun '19, 11:09

question was seen: 1,657 times

last updated: 10 Jun '19, 20:30

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum