Hey,

basically I was setting up an osm tileserver. Now I'm at one point where I can't fix the problem by myself. So here's my problem:

When I run renderd -f -c /usr/local/etc/renderd.conf I get the following output:

renderd[28482]: Rendering daemon started renderd[28482]: Initiating reqyest_queue iniparser: syntax error in /usr/local/etc/renderd.conf (7): -> ;[renderd01] iniparser: syntax error in /usr/local/etc/renderd.conf (14): -> ;[renderd02] iniparser: syntax error in /usr/local/etc/renderd.conf (33): -> ;** config options used by mod_tile, but not renderd ** iniparser: syntax error in /usr/local/etc/renderd.conf (45): -> ;[style2] iniparser: syntax error in /usr/local/etc/renderd.conf (52): -> ;** config options used by mod_tile, but not renderd ** renderd[28482]: Parsing section renderd renderd[28482]: Parsing render section 0 renderd[28482]: Parsing section mapnik renderd[28482]: Parsing section default renderd[28482]: config renderd: unix socketname=/var/run/renderd/renderd.sock renderd[28482]: config renderd: num_threads=4 renderd[28482]: config renderd: num_slaves=0 renderd[28482]: config renderd: tile_dir=/var/lib/mod_tile renderd[28482]: config renderd: stats_file=/var/run/renderd/renderd.stats renderd[28482]: config mapnik: plugins_dir=/usr/lib/mapnik/input renderd[28482]: config mapnik: font_dir=/usr/share/fonts/truetype renderd[28482]: config mapnik: font_dir_recurse=1 renderd[28482]: config renderd(0): Active renderd[28482]: config renderd(0): unix socketname=/var/run/renderd/renderd.sock renderd[28482]: config renderd(0): num_threads=4 renderd[28482]: config renderd(0): tile_dir=/var/lib/mod_tile renderd[28482]: config renderd(0): stats_file=/var/run/renderd/renderd.stats renderd[28482]: config map 0: name(default) file(/home/betrieb/src/openstreetmap-carto/mapnik.xml) uri(/hot/) htcp() host(tile.openstreetmap.org) renderd[28482]: Initialising unix server socket on /var/run/renderd/renderd.sock socket bind failed for: /var/run/renderd/renderd.sock

I also tried the answers from that post from stackoverflow but it didn't help. Anyone another idea that can make it work?

Best regards,

N3x

asked 29 Apr, 12:41

N3x's gravatar image

N3x
51346
accept rate: 33%

edited 29 Apr, 12:59

Which Linux distribution are you running?

(29 Apr, 13:04) Frederik Ramm ♦

ubuntu 18.04 lts server

(29 Apr, 13:08) N3x

Do you have a /var/run/renderd directory? Otherwise :

Blockquote

sudo mkdir /var/run/renderd
permanent link

answered 29 Apr, 18:31

yvecai's gravatar image

yvecai
1.3k1024
accept rate: 11%

I already created that folder before running it

(30 Apr, 07:08) N3x
1

What are the access rights to that folder and as what user are you trying to create a socket in there?

(30 Apr, 09:56) SomeoneElse ♦

Didn't thought about that. Created with root and not it belongs to the user I'm executing the command with. Getting this output now: https://pastebin.com/pBADCg0P And when I try to open it in my Brwoser I get another error which I can't seem to get right now

(30 Apr, 10:54) N3x
1

"An error occurred while loading the map layer 'default': Could not create datasource for type: 'postgis' (no datasource plugin directories have been successfully registered)" suggests you haven't don't the postgis part of that postgres setup. Maybe have a read of https://switch2osm.org/manually-building-a-tile-server-18-04-lts/ and see what you might be missing?

(30 Apr, 10:57) SomeoneElse ♦

Funny thing is that I'm builing it using these instrustions. Just tried to do the postgres steps again but it seems like I already did everything right. I can only try to set up a new Server.

(30 Apr, 12:16) N3x

You don't have multiple versions of postgres by any chance do you? Perhaps one has postgis set up but one not.

(01 May, 11:21) SomeoneElse ♦

I don't. I tried to reinstall psql and correctly choose the owners but it still won't work. Warnings + Errors: https://pastebin.com/VhcaXtPC Got any other idea?

(02 May, 12:53) N3x

I was checking that pastebin and went to the file written in the error. Here's what I got: https://pastebin.com/WwEYdyLn Is there any problem with that line or the whole layer?

(03 May, 07:57) N3x
1

That still says "Could not create datasource for type: 'postgis' (no datasource plugin directories have been successfully registered)". You'll need to resolve that before you can proceed. You say "I already did everything right" yet your computer disagrees with you.

Arguing with inanimate objects is rarely productive; and unfortunately only you know what you have actually done to get to where you are. Trying everything again on a new server (a small virtual machine, perhaps) would be one way to investigate what went wrong.

(03 May, 11:14) SomeoneElse ♦

Well... I set up a new VM and tried it again. Checked every step and set everything right. Still won't work. 2 VMs, same instructions, same result. Both won't work like they should.

(08 May, 07:51) N3x
showing 5 of 10 show 5 more comments

Problem fixed - no answers needed anymore

permanent link

answered 23 May, 15:18

N3x's gravatar image

N3x
51346
accept rate: 33%

So what was it in the end?

(23 May, 15:30) SomeoneElse ♦

"What are the access rights to that folder and as what user are you trying to create a socket in there?" that comment helped a lot. And the database error was because I had to change plugins_dir=/usr/lib/mapnik/input to plugins_dir=/usr/lib/mapnik/3.0/input

(23 May, 15:34) N3x

Could you explain what you did to solve it? I'm having the same problem. My plugins_dir is ok, the access rights seems to be my problem.

(07 Jul, 03:28) carlosguedes
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×162
×85
×21

question asked: 29 Apr, 12:41

question was seen: 782 times

last updated: 07 Jul, 03:29

powered by OSQA