Revers geocoding with high zoom level doesn't return the full address. for example city is missed in this request

zoom = 14

while zooming out shows the missing city field

zoom = 10

so my question is how to get the full address with high zoom levels?

asked 23 Apr '19, 13:27

Nagy's gravatar image

accept rate: 0%

Nominatim doesn't know how big the city is. The OSM data only contains the center point (node) of the city On zoom level 14 it find a smaller feature (island) and doesn't know it belongs to a city. On zoom level 10 it ignores all smaller features and looks for the nearest city more of less by distance (in other words the algorithm is guessing).

Adding a boundary (OSM relation) like for the city helps. Alternatively setting is_in tags to the suburbs and islands belonging to the city

permanent link

answered 23 Apr '19, 13:58

mtmail's gravatar image

accept rate: 28%

Thanks for the response, but how can I achieve that with the reverse get call? ex:

(23 Apr '19, 14:19) Nagy

Nominatim doesn't know how big the city is. Somebody needs to add more data to the OSM database first.

(23 Apr '19, 14:22) mtmail
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 23 Apr '19, 13:27

question was seen: 1,377 times

last updated: 23 Apr '19, 14:22

powered by OSQA