Hello, this roundabout https://www.openstreetmap.org/#map=18/48.31988/18.09694 are missing some exits. It has four in total, but navigation shows only two. Any idea how can I fix this? Thank You!

asked 01 Apr, 08:20

AndrejKuna's gravatar image

AndrejKuna
11112
accept rate: 0%

Which navigation software? Did you try others? Looks like GraphHopper correctly reports 4 exits while OSRM only reports 3. Could be due to shared entry/exit nodes as explained by SK53.

(02 Apr, 08:18) scai ♦

Exits and entrances share nodes which may cause them to be miscounted, as well as not allowing the router to apply appropriate penalties for entering & leaving the roundabout (because a vehicle and transit directly from an entrance to an exit). Some of the geometries also look rather odd for a roundabout (notably the S exit).

permanent link

answered 01 Apr, 16:01

SK53's gravatar image

SK53 ♦
22.9k46234360
accept rate: 20%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×69
×33

question asked: 01 Apr, 08:20

question was seen: 409 times

last updated: 02 Apr, 08:18

powered by OSQA