I've been doing a lot of updating in the area where I live and bike. Just to test some of my changes I did a test route from my home town to another remote town in the area. But the route never arrives even though there is an apparently road all the way. I'm looking for suggestions as to what I may have done wrong. The start is: Comitan de Domínguez, Chiapas, México. The destination is: San Antonio Porvenir, La Independencia, Chiapas, Mexico. Other nearby destinations have similar issues. Using a indicated lat/long selection on a remote road is the same area is even stranger since it moves the point. Thanks for any help.

asked 19 Feb '19, 04:28

Daniel%20Ellsworth's gravatar image

Daniel Ellsw...
13113
accept rate: 0%

2

Which routing provider are you using? How long did you wait? It takes a longer time for the routing engine to update than it takes to render your new roads. Rendering is done in a few minutes / hours while routing updates can take up to several weeks.

(19 Feb '19, 05:53) scai ♦
1

Thanks Alex. I knew that and it'd been about 5 days. I was using the routing in openstreetmaps. Others like maps.me can take months. Ed Loach came up with what I am sure is the correct answer. I appreciate your responding...

(19 Feb '19, 18:36) Daniel Ellsw...
1

@Daniel Ellsworth: meta: After you have checked the updated routing, please could you mark an answer as accepted if it solves your problem.

Please note that it is not openstreetmaps but OpenStreetMap! :-) We have just ONE database - although many different maps and applications like routing are made based on this data.

(19 Feb '19, 21:05) aseerel4c26 ♦

It'll be awhile since I can check the updated routing. But I'm happy with the answer and I learned some other stuff in the process. Where do I indicated answer accepted? I gave a thumb up and also gave some points but don't see where to mark the answer from Ed as accepted.

(19 Feb '19, 21:21) Daniel Ellsw...

@Daniel Ellsworth: see the link in the comment above yours: it is the check mark symbol (check mark).

(20 Feb '19, 06:27) aseerel4c26 ♦

Looking for example at this route the route finished part way along a longer way. Checking the next turning that I would expect it to take, onto this way, the end node is only part of that way, and not the road you would be turning off. If you switch to an editor and zoom in close you'll see the two roads aren't joined.

Once you have joined them it will take some time before the routers update as per scai's comment above.

permanent link

answered 19 Feb '19, 12:12

EdLoach's gravatar image

EdLoach ♦
18.5k15150269
accept rate: 23%

edited 19 Feb '19, 21:07

aseerel4c26's gravatar image

aseerel4c26 ♦
32.2k16241552

Thanks Ed. That helped a lot. I simply zoomed in to move the point onto the main road. However. I could still move the point off the line (the main road). So instead I added another node on the main road and extended it. Then gave it the same characteristics as the junction road and merged that segment with the junction road. Now they are "linked" and moving my joining point/node shifts all three sections radiating from it. I don't know if I had to do all that but it certainly is connected now! I did the same on a couple that had warnings of "way end node near other way" and that also took care of those problems. I'm sure the routing will work fine now - eventually when it's been updated. Thanks again for the heads up.

(19 Feb '19, 18:32) Daniel Ellsw...

@Daniel Ellsworth: I am just curious (and for others), where did you see the "way end node near other way" warnings? In one of the error detection tools - but only after this question? Yeah, always worth to have a look at possible(!) problems.

Thanks for your attempt to fix it!

(19 Feb '19, 21:03) aseerel4c26 ♦

It was in the warnings when I did the upload. I canceled the upload and the validation results show in the right hand side panel. Then I clicked on the warnings and it was in there. Right clicking on it gives you the option to go to the error. I fixed it as I described above and it worked fine. To repeat. In this case I simply pulled back on the end node so it was away from the other. Then I clicked on the junction node where it had been and extended a line to the pulled back end node. I changed that two point segment to be the same as the junction line and then combined them. The error didn't show when I did the update again. The two highways were actually different and it worked fine since I didn't try to combine them.

(19 Feb '19, 21:17) Daniel Ellsw...
1

@Daniel Ellsworth: ah, I see - you used the editor JOSM. Okay, its error detection tool "validator" is by default checks modified objects when you start the upload dialogue, perfect! I wrongly assumed you had used the in-website editor iD, where I did not know such a feature yet.

Your edit is fine. The new junction node https://www.openstreetmap.org/node/6289394057 is a part of both streets - so routing can use this junction now. The Graphhopper routing on the osm.org page will update in a few days.

A bit easier than creating a new way segment and joining them, would have been to select the end node and then select "Move node onto way" (shortcut N) from the JOSM "Tools" menu (only works if you have zoomed out far enough, that far that the node actually nearly touches the other way).

(20 Feb '19, 06:46) aseerel4c26 ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×19

question asked: 19 Feb '19, 04:28

question was seen: 516 times

last updated: 20 Feb '19, 06:46

powered by OSQA