Hi,

I have the following problem:

I want to edit in Potlatch2 my uploaded trace (valberttour_2.gpx) but I get the following result:

Error: Couldn't load the map

What I did:

1) I traced a way with my Garmin GPS eTrex Vista HCx

2) Loaded the trace to my computer and saw the trace in MapSource

3) Edited the trace (removed some points)

4) Exported to gpx-format

5) Uploaded the file with 136 points (valbert_tour_2.gpx) to OpenStreetMap

6) Got an email that trace is uploaded

7) I can see the uploaded trace in "Your GPS trace" (but I see only a line in the small icon-image; my way was a loop trail)

8) Now, I wanted to add/edit my way to OpenStreetMap via Potlatch2 (I used the Edit-Button in "Your GPS traces")

9) Got the error message. See above.

I used two underlines in my filename "valbert(undeline)tour(undeline)2.gpx". Now I see that only one underline can be shown in this forum. Can it be that only one undeline is accepted in filenames?

Can anybody help?

Thank you

Stephan

asked 02 Aug '11, 15:12

Stephan1000's gravatar image

Stephan1000
1222
accept rate: 0%


"Couldn't load the map" is very unlikely to have anything to do with your GPS trace. This is probably just coincidence.

Rather, it means that Potlatch asked for map data from the OSM server, and the server couldn't respond for some reason. It may just be that the server was having problems at that point in time.

The one possibility that might be related to your GPS trace is that you might have a bogus lat/long in it - that is, a point outside the usual -180 to +180 range. But I'd be surprised if the server accepted that trace in the first place.

permanent link

answered 03 Aug '11, 13:14

Richard's gravatar image

Richard ♦
27.0k39239356
accept rate: 20%

edited 03 Aug '11, 13:14

It seems that your trace was uploaded and is available (you got the mail and see it in "Your GPS traces"). Is the number of recognized points (in the email) the same as your file (136 points seems quite few). The underscores "_" should not cause any problem, you can use as much of them as you like.

What happens if you click in "Your GPS traces" on the filename-link? It should load the trace and show you a bigger preview.

Can you see other traces in Potlatch2? There might be currently in problem in Potlatch (I see "object object" where there should be the GPS-traces menu). Have you tried to open the trace in JOSM? You simply start JOSM, go to FILE->OPEN and open your local GPS-trace (or you hit the button with the green arrow downwards and load all gps-files in the download area).

permanent link

answered 02 Aug '11, 16:31

dieterdreist's gravatar image

dieterdreist
3.6k103466
accept rate: 3%

1

@dieterdreist

Thank you. I loaded my trace file in MapSource again and saw there were a lot of traces (6) in this file. Some traces had only one point. I deleted, saved again only one trace (now 120 points), uploaded to OSM and now it works.

Is thera a problem to export (save to *.gpx) from MapSource traces with more than one trace? Or do I have to join the traces before export?

Thanks

Stephan

(02 Aug '11, 17:35) Stephan1000

as far as I know you can have lots of traces/tracks in one file (I never had problems with these and they are also highlighted in the preview on osm.org). I think everytime you stop recording and restart a new track is created. You can see this when you open your gpx-file with a text-editor: Every section that is between <trk> and </trk> is considered a new track.

(02 Aug '11, 17:51) dieterdreist

I set the GPS (60Csx in my case) to record one point a second in gpx-format on the external memory. This way you get the uncompressed gpx.-points, 1 point a second, also without mapsource (you can simply mount the card like an external drive and copy the files to your local disk). This file doesn't contain the waypoint though, these are stored in another gpx-file I get when downloading the data via Garmin's protocol.

(03 Aug '11, 10:10) dieterdreist

I set my vista to:- main menu, tracks,time, 1 second and record to data card. and set=up, map,tracks, track log auto. My uploaded traces have on average 12000 points.( 5 hours walks) I only cut off the drive to/from the walk,unless road is not on the map. note you must record to data card or you may run out of space on this setting, but a 4GB card will hod a great britain osm map and dozens of traces.I also find that its better to take the trace via a card reader otherwise The vista is still adding data while being read and this as sometimes caused problems downloading from vista to my PC track editing software.I have sent gpx files to the card and to the vista they will need different names otherwise the will overwrite each other.the normal recorded traces are named with the date as you will have noticed.

permanent link

answered 03 Aug '11, 01:01

andy%20mackey's gravatar image

andy mackey
11.5k73124254
accept rate: 5%

edited 03 Aug '11, 09:12

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×212
×64

question asked: 02 Aug '11, 15:12

question was seen: 4,383 times

last updated: 03 Aug '11, 13:14

powered by OSQA