Hi all,

I'm new here, I looked up and tried to find an answer to my question, but could find one... Sorry if this has been answered already!

So I made some small edits to my local hiking trail, because the different trails were not connected together and you couldn't navigate them on a map. On this image:

alt text

-- 1 -- The 2 arrows are pointing short sections of the trail that were not mapped at all. I connected the trails together (bottom arrow) and I connected the trail to the road (top arrow) (these changes can be seen there: https://www.openstreetmap.org/way/470643312
https://www.openstreetmap.org/way/128944297 )

-- 2 -- The box is showing a trail that wasn't appearing on the map for hiking. I changed the "highway" tag of the line (that was already there) from "path" to "footway". - see my edit here: https://www.openstreetmap.org/changeset/66693927 - and the history of changes here: https://www.openstreetmap.org/way/666463749/history

So now after 3 or 4 days, the changes are appearing on Graphhopper - great!

However, when you plan a route it still won't navigate through any of these section I "fixed", as if they were nonexistent: In this Graphopper route, the navigation should bring you from the start through steps 1,2,3,4 and 5 and then to the destionation, but instead it goes all around and you can see the portion of the trail it ignores...

Any idea why? What should I do for this to work out properly? Thanks!

asked 29 Jan, 21:14

Laurenzo_214's gravatar image

Laurenzo_214
31114
accept rate: 0%

edited 02 Feb, 10:13

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16237548

1

For future reference, as of today the routing is working on Graphopper! I just takes a little longer.

(01 Feb, 20:28) Laurenzo_214

Hi Laurenzo_214, I used JOSM to have a look at your problem and found this : Changeset 66649465 on Sentier du Col and Sentier du ruisseau Fortier on 1/26/19 7:54 AM with iD 2.13.0

If you want to do some serious editing in Osm you might want to have a look at JOSM it's a far better editor than iD, Imo

I checked your edits and found nothing wrong. I used the JOSM Validator to check the whole area and there were a few warnings that should NOT influence the routing there.

1) Warning in Josm : Similar named ways : Sentier du Col Sentier du Mont-Mégantic Grande-Ourse à Pléiades Sentier du mont Mégantic This is about a Crossing of 4 ways near Refuge Grande Ourse Because JOSM sees a difference in "Sentier du Mont-Mégantic" and "Sentier du mont Mégantic" picky but we want a perfect map :)

I corrected this warning for you.

2) Warning in Josm : Crossing waterway/highway Ruisseau Deloge,Sentier du Mont-Mégantic Crossing waterway/highway Sentier du Ruissea de la Montagne,Ruisseau de la Montagne

The hiking path crosses a little stream on several places. I did not correct this because I don't know if there is a bridge or a place where you can wade through the stream.

I'm in The Netherlands and I use BaseCamp for routing. I don't have a map for Canada and could not find a recent enough Garmin extract. I downloaded a map in OsmAnd which I use for navigating on my Samsung Galaxy. OsmAnd also does not route there. The OsmAnd map is also not recent enough.

I downloaded this map : http://download.geofabrik.de/ quebec-latest.osm.pbf, suitable for Osmium, Osmosis, imposm, osm2pgsql, mkgmap, and others. This file was last modified 11 hours ago and contains all OSM data up to 2019-01-29T21:15:02Z. File size: 403 MB;

I used QMapShack with the recent standard OpenstreetMap as a backgroud. I build a Database for Routino from the above geofabrik download and made a hiking route in QMapshack.

It all worked well. Your edits are routing correctly. Here is a link of the route on my Google Drive :

https://drive.google.com/file/d/1BqgbO9OH2iZ8ySBr6VBuvaof9GRfHOq5/view?usp=sharing

So, you can use http://download.geofabrik.de/ Routino and QMapShack to make a hiking route from your latest edits or just wait till Graphopper gets a new update.

hth Gys

permanent link

answered 30 Jan, 11:32

Gys%20de%20Jongh's gravatar image

Gys de Jongh
5431513
accept rate: 13%

Hi Gys,

Not sure I want to get into serious map editing right now, it's mostly that I find it very annoying when trying to get navigation stats (distance, elevation gain, etc.) and there are gaps in trails like this!!

Thanks for your answer and for taking the time to look at it :) Next time I go there I'll make sure to take note of which stream crossing has/doesn't have a bridge and I'll come back to fix that.

I also use OsmAnd, I hadn't though about looking there. I just updated the map and indeed the new trails are not showing yet. Thanks as well for the geofabrik suggestion :)

(30 Jan, 20:22) Laurenzo_214

Using the new data for display can happen more quickly than using the same data for routing and navigation. I suggest you see if Graphhopper indicates anywhere how often they update their routing database from OSM.

For foot routing there shouldn't be any difference between between "path" and "footway". I personally use "footway" for wide smooth, generally hard surfaced, ways as found in suburban and urban areas. And I use "path" for the typically more narrow and unsurfaced ways that I hike on in the hills and mountains. My division between the two is generally based on deciding if a parent could push a baby stroller along the way, if so then footway if not then path.

permanent link

answered 29 Jan, 21:51

stf's gravatar image

stf
7.5k962119
accept rate: 19%

Thanks stf, I though updating display and routing/navigation was the same. Here is what they say in the FAQ: "How long does it take after I updated the data on OpenStreetMap.org? A change of the data at openstreetmap.org will be considered in our APIs usually after 2 days and at least every week. Except for the Geocoding API: the default provider can take up to 7 weeks and the nominatim provider should be updated within one week."


Regarding path vs footway, I understand what you are saying, but apparently there is a difference.

Before I made the change, there were no line/road/trail showing at all on the map in the red box area I outlined, but there was a line tagged "path" that I could see in the editor.

So I looked in the editor to find the difference between the other trails that I could see and the line that I couldn't see, and the only difference was the "highway" tag, which is why I changed it's value from "path" to "footway". And now, after my change, the trail is showing, so I guess there is a difference, but I can't tell more.

(29 Jan, 22:12) Laurenzo_214
1

The path was only added a few days ago (about a day before you edited it), so the reason you couldn't see it on the map is probably just that the tiles hadn't re-rendered yet. Usually the tiles at the higher zooms on the "Standard" rendering will update after about a minute, but sometimes there are delays or your browser shows a cached version. Given a bit more time, the highway=path would have shown.

(30 Jan, 16:45) alester

Thanks alester, I hadn't seen that it was a brand new path!

(30 Jan, 19:51) Laurenzo_214
1

Stf, just found that according to default access restriction, a "path" and a "footway" are not the same.

See here : https://wiki.openstreetmap.org/wiki/OSM_tags_for_routing/Access-Restrictions

A footway excludes bicycles, horses and moped by default.

(02 Feb, 01:48) Laurenzo_214
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×163
×134
×37
×27
×12

question asked: 29 Jan, 21:14

question was seen: 366 times

last updated: 02 Feb, 10:13

powered by OSQA