I'm frustrated to find that use of a mouse zoom wheel on www.openstreetmap.org now changes the zoom level for me by 3 levels. I thought this was a problematic setting on my own computer, but I see that a colleague is equally frustrated. Is this intentional? Does it effect everyone? Is it going to get fixed? It's horrible... always needing to adjust zoom level with the buttons on the edge of the window.

asked 29 Jan, 10:10

Rostranimin's gravatar image

Rostranimin
2453412
accept rate: 0%

edited 29 Jan, 18:52

aseerel4c26's gravatar image

aseerel4c26 ♦
32.1k16239551

1

Not for me, scrolling just zooms for a single step. Firefox Quantum 60.4.0 on Linux. Which operating system and browser are you using?

(29 Jan, 10:29) scai ♦

I don't see this either, just the usual single step (Chrome, Windows 10).

(29 Jan, 12:56) alan_gr

@Rostranimin, what browser on what OS are you using? Also is there any other information that might be relevant?

(29 Jan, 13:53) SomeoneElse ♦

I don't know whether the last comment on this (old) Leaflet issue is relevant https://github.com/Leaflet/Leaflet/issues/1794

(29 Jan, 15:19) EdLoach ♦

Note my own answer to the question below. I'm on Chrome when encountering the problem, Windows 7. It's new. At the moment I only know that it seems to be a problem also for colleagues (same company, same PC model, same Windows build, etc - probably also on Chrome, but I didn't check).

(29 Jan, 18:08) Rostranimin

EdLoach - does www.openstreetmap.org use Leaflet to serve up the map? That wouldn't surprise me - I just never checked before.

(29 Jan, 18:12) Rostranimin

@Rostranimin: yes, it does use Leaflet.

(29 Jan, 18:27) aseerel4c26 ♦
showing 5 of 7 show 2 more comments

I had this same problem recently which I resolved by going to the Windows Mouse settings and changing the "Choose how many lines to scroll each time" setting to 3 (the default).

This assumes the "Roll the mouse wheel to scroll" setting is set to "Multiple lines at a time".

permanent link

answered 03 Feb, 16:46

JohnHovercraft's gravatar image

JohnHovercraft
414
accept rate: 0%

edited 04 Feb, 13:53

No there hasn't (to my knowledge).

I'm answering my own question. Transferring to another system completely (different building, organisation, etc) the problem goes away. At the moment it appears to me that somehow this is something which is a problem only within my office (unless anyone else confirms the behaviour).

Why this is happening remains a mystery.

permanent link

answered 29 Jan, 18:05

Rostranimin's gravatar image

Rostranimin
2453412
accept rate: 0%

@Rostranimin: possibly an organization-wide change for your computer settings?

(29 Jan, 18:53) aseerel4c26 ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×87
×86
×3

question asked: 29 Jan, 10:10

question was seen: 546 times

last updated: 04 Feb, 13:53

powered by OSQA