I've attempted to figure out the solution to this by reading the documentation as it seems like the "why aren't my edits showing" question is probably asked every other day...

That being said, I've made a couple edits and none have published so far. The buildings/edits are visible in the editor, but not on the public map.

I've tried doing a force refresh(ctrl+shift+r) empty cache and force reload(right click refresh while inspect element is open) and even using other devices. I'm fairly certain at this point its not a local caching issue.

Here is an example of my changes: https://www.openstreetmap.org/changeset/62326197

All of my edits show up as "Closed by Joeybab3 x amount of time ago" immediately after publishing. I've tried adding relevant hashtags and have been constantly force refreshing it for two days now.

asked 07 Sep, 20:43

joeybab3's gravatar image

joeybab3
303
accept rate: 0%

1

It could be useful to provide your current location, as there may be hiccups in the tile cache which serves your country.

(07 Sep, 21:57) aseerel4c26 ♦

My location is southern california

(07 Sep, 22:01) joeybab3

as a workaround (if you need to see what you have drawn outside the editor) you can view the humanitarian map style (see the layer menu on osm.org) which also updates quite fast, usually. Your building is visible there. As far as I know it uses different tile serving infrastructure.

(07 Sep, 23:10) aseerel4c26 ♦

It does show fine here: alt text

permanent link

answered 07 Sep, 21:38

Hjart's gravatar image

Hjart
2.7k32353
accept rate: 16%

same for me (from Germany)

(07 Sep, 21:58) aseerel4c26 ♦

Thanks for testing that for me. It's the strangest thing... I've tested it on a few computers that have never even opened openstreetmap and they all show it without that update.

(07 Sep, 22:01) joeybab3
2

Yeah, I don't see the buildings in the US. There is a new server, there may be some issue to work out.

As far as the data, as long as the changeset shows up in your history it has been fully saved.

(07 Sep, 22:48) maxerickson
2

Indeed, the sysadmins noticed that a dependency of the tile update software was missing on the server and installed it. The tiles are updating now.

(07 Sep, 23:53) maxerickson
1

Thanks for the update, I'll go ahead and close it now. I just got unlucky with the time I chose to join OSM I guess.

(10 Sep, 17:17) joeybab3
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×168
×100
×65

question asked: 07 Sep, 20:43

question was seen: 128 times

last updated: 10 Sep, 17:18

powered by OSQA