Trying my first OSM install to generate map of Indonesia. Following https://switch2osm.org/manually-building-a-tile-server-16-04-2-lts/ Got through problems with package name changes and nodejs version issues. Thought I was unstoppable until I failed check when running: $ renderd -f -c /usr/local/etc/renderd.conf

renderd[11486]: An error occurred while loading the map layer 'ajt': Postgis Plugin: ERROR: Unicode escape values cannot be used for code point values above 007F when the server encoding is not UTF8 at or near "\2212'"

LINE 58: ...LACE(ROUND((tags->'ele')::NUMERIC)::TEXT, '-', U&'\2212'), U... ^ in executeQuery Full sql was: 'SELECT * FROM (SELECT

<snip obscenely="" long="" sql="" query="">

) AS text_poly LIMIT 0' encountered during parsing of layer 'text-poly' in Layer at line 44438 of '/home/osm/src/openstreetmap-carto/mapnik.xml'

The referenced line in mapnik.xml looks harmless: <layer maximum-scale-denominator="750000" name="text-poly" srs="+proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0.0 +k=1.0 +units=m +nadgrids=@null +wktext +no_defs +over">

But the reference to "when the server is not UTF8" has me thinking the "server" is renderd. But there's nothing in the renderd.conf that jumps out at me. I really want to display local names, so UTF-8/Unicode support is going to be needed.

Ideas?

asked 26 Aug '18, 05:41

Eric%20Phelps%20exz5z5's gravatar image

Eric Phelps ...
1612
accept rate: 0%


The server this refers to is the PostgeSQL server. On the page linked to you can see the line

createdb -E UTF8 -O renderaccount gis

which should make sure that your database is UTF8. Please refer to the PostgreSQL manual for details.

permanent link

answered 26 Aug '18, 08:22

Jochen%20Topf's gravatar image

Jochen Topf
4.3k54362
accept rate: 32%

And so it was! Apparently there's a change in Postgres where you have to specify the -T option on createdb in order to get UTF-8. And no way to fix an existing database :( so I had to delete and re-create it. And then renderd complained it was missing "/usr/local/etc/renderd.conf" (which was, in fact, missing). And this is where I've decided to slick the whole thing and start over. And pay a lot more attention to things.

Seriously though, thanks for the quick help!

(27 Aug '18, 03:30) Eric Phelps ...
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×217
×72
×4

question asked: 26 Aug '18, 05:41

question was seen: 249 times

last updated: 27 Aug '18, 03:30

powered by OSQA