I am an experienced user of OSM maps on etrex30, but after uploading my gmapsupp.img my etrex did not show any map anymore, even not the base map etrex has standard built in. I did enable the maps (and tried to unable the base map), installed the OSM map on the memory card or on the standard directory, in the appropriate GARMIN directory. I did a reset of my device as well as an update but all did not work. I also tried renaming the gmapsupp.img. It is the single OSM map in my device (the others I deleted). The only thing I see on my screen are the saved routes and waypoints. Zooming is not the issue (I tried that). Any ideas? I would be quite grateful!

asked 10 Jul, 11:48

aadaad's gravatar image

aadaad
11112
accept rate: 0%

edited 10 Jul, 21:59

aseerel4c26's gravatar image

aseerel4c26 ♦
30.7k15230519

Does it work with other maps? Perhaps you have the old gmapsupp.img that used to work - does that still work?

(10 Jul, 11:53) SomeoneElse ♦

Thank you for this reply. No, I tried that as well as well as different maps from OSM.

(10 Jul, 14:48) aadaad
2

Well if a map that used to work no longer does, then it's not a problem with the map. Try giving the contacts on the SD card a clean and trying again.

(10 Jul, 15:25) SomeoneElse ♦

I like to have my maps on a couple of micro SDs. This means i can go back to a working map, if the new download does not work. I try to avoid using the devices internal memory if possible. I recently had a new Oregon 700 for a week and i used Basecamp to transfer some stuff to it, It locked and i couldn't reset it even with Garmins instructions. The device was returned to the retailer and i got a refund. If i had sent the device back to Garmin they would have sent me a refurbished one which i wasn't pleased about. This is my first Garmin to crash in ten years the others all continued to work for at least four years each.

(10 Jul, 22:47) andy mackey

I've seen similar behavior with my eTrex 30 that seems to resolve by powering down, removing the batteries and SD card, re-inserting the batteries and SD card, and powering up. As SomeoneElse said, cleaning the contacts might also be good.

If it's still not working, save all your current waypoints and tracks and then try "Reset All Settings" under the "Reset" menu. (I know you already did that, but be stubborn.)

If that's no help, try a different, freshly formatted SD card -- or just backup the data from the current card and reformat it. The eTrex doesn't have the ability to format cards itself (at least mine doesn't -- haven't upgraded the firmware in a long time) so you'll have to use a computer, see Garmin's support page. Then recreate the "Garmin" directory and try putting the maps there again.

permanent link

answered 10 Jul, 15:43

jmapb's gravatar image

jmapb
75511218
accept rate: 16%

Thanks a lot for your helpful comments but all of them I've tried already (e.g. by removing the SD card and putting the map on the built-in card).

(10 Jul, 16:12) aadaad
2

The eTrex will not read maps from the built-in memory card -- only from the Garmin directory on the micro SD card. That's my experience, anyway. It sounds like the micro SD card is not mounting properly (that's why your tracks and waypoints are still showing -- they're stored in the built-in memory card) so either the card is defective, or it's not seated quite right, or the contacts are dirty... or there's a mysterious software glitch.

Trying a different SD card (or the same SD card in a different eTrex) is the only way I can think to narrow down the problem. Good luck!

(10 Jul, 16:33) jmapb

Thanks - my SD card works well since in Setup > Map > Select map, the OSM map is visible and enabled. But also, the basic map Garmin has in the built-in memory is not showing up (while it is enabled).

(11 Jul, 13:48) aadaad

A few weeks ago i installed an opentopomap download onto a micro sd ( 8 or 16GB from memory) for a walking pal. I fitted it into his Etrex 20 (which i would expect to have a very similar OS to the 30). The Opentopomap displays contour lines and works fine from a micro sd. The user tells me he very pleased tells and that it has transformed the the Garmin Etrex 20's usefulness now that it has a useable map for countryside walk planning and leading.

(30 Aug, 17:16) andy mackey

Very user friendly Link for a Garmin osm map. http://garmin.opentopomap.org/

(30 Aug, 17:21) andy mackey

Thanks - my SD card works well since in Setup > Map > Select map, the OSM map is visible and enabled. But also, the basic map Garmin has in the built-in memory is not showing up (while it is enabled).

permanent link

answered 11 Jul, 13:48

aadaad's gravatar image

aadaad
11112
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×392
×273
×65
×3

question asked: 10 Jul, 11:48

question was seen: 375 times

last updated: 30 Aug, 17:21

powered by OSQA