Hello,

I am attempting to install Nominatim on Ubuntu 14.04 with php5. During the attempt to run setup.php it fails on this line: https://github.com/openstreetmap/Nominatim/blob/master/utils/setup.php#L88

With output:

2018-07-04 06:31:38 == Create DB
Segmentation fault (core dumped)

My version of PEAR::DB is 1.9.2.

If I deliberately break the connection string, it will return a 'DB not available' error without throwing a segfault. The command I ran was:

./utils/setup.php --osm-file /srv/nominatim/australia-latest.osm.pbf --all 2>&1

I get the same results if I run with root (I know that the setup instructions warn against installing as root).

asked 04 Jul '18, 07:56

jordanglue's gravatar image

jordanglue
11112
accept rate: 0%

Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×560
×53
×4

question asked: 04 Jul '18, 07:56

question was seen: 348 times

last updated: 04 Jul '18, 07:56

powered by OSQA