I installed the rails port, imported North Dakota from http://download.geofabrik.de/north-america.html, edited an area with ID editor, then extracted the diff. Upon looking at the diff output file XML (8 kb), I see all the nodes there and it all looks correct.

I truncated the db, imported the same pbf from Geofabrik, and then I tried to import the diff but it's not working.

Running Osmosis V 0.44.1

osmosis --read-xml-change testChange3.osc --write-apidb-change dbType="postgresql" host="localhost" database="openstreetmap" user="openstreemapPGuser" password="secretPW" validateSchemaVersion="no"

Says it completed, but the test road is not actually showing in ID editor.

I also tried truncating the DB again, then importing a combined file which also seems to not work.

osmosis  --read-xml-change file="testChange3.osc" --read-pbf file="north-dakota-latest.osm.pbf" --apply-change --write-xml file="output.osm"

I also tried downloading an OSC from ID editor which provides "new" node ids such as "<node id="-8"..." Osmosis generates the error "The entity timestamp attribute is missing."

How is an OSC supposed to be imported so that it's visible within the ID editor?

asked 16 May '18, 23:41

caleb87z's gravatar image

caleb87z
16225
accept rate: 0%

edited 17 May '18, 00:44

Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×219

question asked: 16 May '18, 23:41

question was seen: 327 times

last updated: 17 May '18, 00:44

powered by OSQA