Hi forum,

I tried to follow the interesting tutorial ( switch2osm.org/manually-building-a-tile-server-16-04-2-lts) for building an independent tile server for Ubuntu 16.04.

I started with a new Ubuntu server in a virtualbox machine. Unfortunately it does not work and I can not understand why.

On the browser the requested URL /hot/0/0/0.png was not found on this server (err 404). On the server side, we can read Received request for map mayer 'ajt' which failed to load.

When I launch the renderd, an error occurs which is

"An error occured while loading the map layer 'ajt' : Postgis Plugin : ERROR relation     "planet_osm_polygon" does not exist.

I had to make a mistake somewhere.

Does anyone have a suggestion to help me ?

Thanks a lot & sorry for that newbie issue.

Sincerely,

David.

asked 11 Apr, 09:22

draimond's gravatar image

draimond
36113
accept rate: 0%

edited 12 Apr, 00:41

FredrikLindseth's gravatar image

FredrikLindseth
646111829

1

I'd suggest that you restart "renderd" and post the errors that you see there in a github gist or similar, and then post a link to that here.

(11 Apr, 11:40) SomeoneElse ♦

If "planet_osm_polygon" does not exist, then something has gone wrong at the osm2pgsql step.

permanent link

answered 12 Apr, 19:49

yvecai's gravatar image

yvecai
1.1k920
accept rate: 11%

Hi, Thanks a lot. You are right. I had a problem at this stage. I did the whole procedure again and it works now. Regards. David.

(14 Apr, 06:44) draimond
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×110

question asked: 11 Apr, 09:22

question was seen: 402 times

last updated: 16 Apr, 08:55

powered by OSQA