Hi,

I set up my own OSM server and launch it in the development mode. I have a backend RDS server in AWS with data populated. Also, per instruction (https://github.com/openstreetmap/openstreetmap-website/blob/master/CONFIGURE.md), I registered application (in localhost) and update consumer key in application.yml. However, every time when I try to save my local changes in the iD editor, a popup window shows up to ask permission. After clicking "Grant Access", I always see an error message: No route matches [GET] "/land.html". Full trace is attached below:

actionpack (5.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:63:in call' actionpack (5.1.5) lib/action_dispatch/middleware/show_exceptions.rb:31:incall' railties (5.1.5) lib/rails/rack/logger.rb:36:in call_app' railties (5.1.5) lib/rails/rack/logger.rb:24:inblock in call' activesupport (5.1.5) lib/active_support/tagged_logging.rb:69:in block in tagged' activesupport (5.1.5) lib/active_support/tagged_logging.rb:26:intagged' activesupport (5.1.5) lib/active_support/tagged_logging.rb:69:in tagged' railties (5.1.5) lib/rails/rack/logger.rb:24:incall' sprockets-rails (3.2.1) lib/sprockets/rails/quiet_assets.rb:13:in call' actionpack (5.1.5) lib/action_dispatch/middleware/remote_ip.rb:79:incall' request_store (1.4.1) lib/request_store/middleware.rb:19:in call' actionpack (5.1.5) lib/action_dispatch/middleware/request_id.rb:25:incall' rack (2.0.4) lib/rack/method_override.rb:22:in call' rack (2.0.4) lib/rack/runtime.rb:22:incall' rack-uri_sanitizer (0.0.2) lib/rack/uri_sanitizer.rb:14:in call' activesupport (5.1.5) lib/active_support/cache/strategy/local_cache_middleware.rb:27:incall' actionpack (5.1.5) lib/action_dispatch/middleware/executor.rb:12:in call' actionpack (5.1.5) lib/action_dispatch/middleware/static.rb:125:incall' rack (2.0.4) lib/rack/sendfile.rb:111:in call' secure_headers (5.0.5) lib/secure_headers/middleware.rb:13:incall' railties (5.1.5) lib/rails/engine.rb:522:in call' puma (3.11.3) lib/puma/configuration.rb:225:incall' puma (3.11.3) lib/puma/server.rb:624:in handle_request' puma (3.11.3) lib/puma/server.rb:438:inprocess_client' puma (3.11.3) lib/puma/server.rb:302:in block in run' puma (3.11.3) lib/puma/thread_pool.rb:120:inblock in spawn_thread'

If I set oauth_10_support to false in application.yml, the authorization process seems to come through. However, the popup window does not go away and the save button is still grayed out. If I reload the page and try to save again, I would still be asked for permission.

Interestingly, the Potlatch editor works perfectly fine. No permission is asked and changes can be saved to database successfully.

Does anyone have a hit what might go wrong?

Thanks!

asked 09 Apr, 06:50

zlzhao1104's gravatar image

zlzhao1104
61225
accept rate: 100%


Never mind. I just resolved the issue. Originally, I only allowed iD to request the “modify the map” permission from user. I just tried to allow it to request all permissions and it worked well.

permanent link

answered 09 Apr, 23:06

zlzhao1104's gravatar image

zlzhao1104
61225
accept rate: 100%

As you cannot accept your own answers, I've marked this as accepted.

(10 Apr, 12:37) SK53 ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×234
×16

question asked: 09 Apr, 06:50

question was seen: 180 times

last updated: 10 Apr, 12:37

powered by OSQA