Hi. I'm not sure what to do here so I'd appreciate some noob help.

There's a railway line in my local area that's been abandoned for years but it's been added to the transport layer on the map. It doesn't show as being abandoned or disused etc, and there's no way to differentiate between active and inactive railway lines.

I've opened the map in the JOSM editor but there doesn't appear to be a way to keep it but make it clear it's not in use.

What's the best way forward? Thanks.

asked 11 Mar, 18:35

GarfyTheCat's gravatar image

GarfyTheCat
3113
accept rate: 0%

Can you provide a link to the area concerned? OSM's "transport" layer doesn't show abandoned railways near me (compare https://www.openstreetmap.org/#map=16/53.1475/-1.3657&layers=T and http://map.atownsend.org.uk/maps/map/map.html#zoom=15&lat=53.1481&lon=-1.36527 - the dotted line you see across the middle of the second link is an abandoned railway, which doesn't appear on the transport map).

(11 Mar, 18:47) SomeoneElse ♦

https://www.openstreetmap.org/#map=14/56.0094/-3.8413

Interestingly it doesn't show on the web map, only on the app. It's definitely in there in the data, tagged as railway/abandoned.

(11 Mar, 18:53) GarfyTheCat

Which app? The object itself seems to be https://www.openstreetmap.org/way/175608413 , by the way.

(11 Mar, 18:55) SomeoneElse ♦
1

OsmAnd for Android

(11 Mar, 18:57) GarfyTheCat

First things first, there's a Google Group devoted to OsmAnd over at https://groups.google.com/forum/#!forum/osmand . I mention that not because asking here is "wrong" (it isn't) but because the people who are most familiar with OsmAnd are more likely to be there rather than here.

It is possible to customise the map styles in use by OsmAnd. This might seem a bit daunting at first but there are quite a few help pages available (though not all may be up to date). A quick search of the OsmAnd Group finds https://groups.google.com/forum/#!searchin/osmand/style|sort:date/osmand/6USzKxxkSv8/11IMgyCsAQAJ and http://osmand.net/help/docs/Custom_Rendering_How-To.htm . What you might be able to find is someone who's made the same change that you are suggesting already.

The other way to go might be to log it as a bug in Github (which I think is here). I can't see an issue for your problem already.

Edit: One thing I should have said before was that I do see the same problem in OsmAnd as you do - it's not just local to you. It only happens if you turn the transport overlay on though - with it turned off you'll still see non-abandoned railway lines, but less prominent.

permanent link

answered 11 Mar, 19:15

SomeoneElse's gravatar image

SomeoneElse ♦
30.5k62318707
accept rate: 15%

edited 11 Mar, 19:18

Great, thanks!

(12 Mar, 11:43) GarfyTheCat

The OpenStreetMap Wiki is the main resource which defines how objects are supposed to be tagged. In this case, the following tags are relevant:

The question how those tagged objects are rendered on a map is entirely up to the renderer / app in question and errors need to be reported there.

In any case, never map for the renderer, but according to the explanations in the OSM Wiki.

permanent link

answered 11 Mar, 19:32

nidi0's gravatar image

nidi0
111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×48
×47

question asked: 11 Mar, 18:35

question was seen: 260 times

last updated: 12 Mar, 11:43

powered by OSQA