https://blog.abysm.org/2016/04/taiwan-gis-resources/ lists

URI: http://landmaps.nlsc.gov.tw/S_Maps/wmts
URI: http://landmaps.nlsc.gov.tw/S_Maps/wms
Referer: http://maps.nlsc.gov.tw/

In JOSM I have tried to enter them in various ways in Imagery Preferences.

The best I could ever get was some blank tiles.

asked 17 Feb '18, 03:00

jidanni's gravatar image

jidanni
285172135
accept rate: 0%

1

legal sidenote: the need for a specific referer suggests that this imaginary is NOT usable by us (in fact it is intended not to be even viewed by everyone). Please do not use it as a source for your contributions. Only use sources where you know the opposite (a explicit positive statement about usability)

(17 Feb '18, 12:30) aseerel4c26 ♦

Yes I want to use those cadastral layers to align an ancient aerial photograph via PicLayer plugin, nothing to do with putting any results into OSM. Just a learning exercise for me. Anyway I found {header} in https://josm.openstreetmap.de/wiki/Maps#WebMapServicesWMS but still don't know the proper way to feed those two URLs into JOSM.

(17 Feb '18, 12:45) jidanni

Try to include this in the URL: {header(Referer,http://maps.nlsc.gov.tw/)} (not tried by me). But it seems for WMS you need to specify also the other parameters (width, ...) with placeholders.

(17 Feb '18, 12:52) aseerel4c26 ♦
1

As a sidenote to the legal sidenote - if you believe that these sources should be listed in the imagery available from JOSM and the other OSM editors then please raise that at https://github.com/osmlab/editor-layer-index .

(17 Feb '18, 12:57) SomeoneElse ♦

To give some more background: WMS servers work slightly different than google/OSM style tile servers and provide a proper API to find out what imagery layers with associated properties are available.

Typical integration with OSM editors involves getting the layer url from the WMS server either by using the GetCapabilities call and then extracting the required URL from the response by using the layer name, or by directly configuring that URL with corresponding placeholders.

What don-vip is pointing out is that the WMS server is actually not configured correctly, well at least not responding to the GetCapabilities call properly, which is a non-starter for any use of the server.

permanent link

answered 18 Feb '18, 23:40

SimonPoole's gravatar image

SimonPoole ♦
38.6k13287612
accept rate: 19%

Capabilities are invalid, there is no layer defined. Please contact the servers admins.

permanent link

answered 17 Feb '18, 12:59

don-vip's gravatar image

don-vip
30056
accept rate: 33%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×521
×32
×2

question asked: 17 Feb '18, 03:00

question was seen: 1,307 times

last updated: 18 Feb '18, 23:40

powered by OSQA