Hi all, I was using RDS instance db.r4.xlarge (RAM - 32GB CPU-4 ) to store the database and do the SQL queries for tileserver. It was working perfectly and getting output. However, when I tried to downgrade the RDS instance to db.r4.large (RAM-16GB and CPU-2vCPU), it is showing the following error.

DEBUG: START TILE ajt 0 0-0 0-0, new metatile renderd[14721]: Rendering projected coordinates 0 0 0 -> -20037508.342800|-20037508.342800 20037508.342800|20037508.342800 to a 1 x 1 tile renderd[14721]: DEBUG: Connection 0, fd 6 closed, now 0 left

Please let me know if someone has any idea about this error.

Thanks Subin

asked 15 Feb, 10:17

subinjp7's gravatar image

subinjp7
16447
accept rate: 0%

edited 16 Feb, 17:11

2

This is not an error message. Can you check if your postgresql log file or your syslog show any messages when you try to access the tile?

(15 Feb, 10:40) Frederik Ramm ♦

I checked the sylog, but could not find anything specific. But in RDS instance, it shows that, connection to the client lost. But I am not sure, what is the reason behind losing the connection..Please help me.

Actually I used EC2 instance:m4.xlarge with 32 GB RAM and RDS instance: db.r4.xlarge with 32GB RAM to run osm2pgsql to convert openstreetmap data in to postgres database. I am currently using the following configuration for accessing full planet database for tileserver. EC2 instance:t2.medium with 4GB RAM for rendering purpose (front end) and RDS instance: db.r4.large with 16GB RAM to store database and run SQL queries.

Please let me know if it is enough to run tileserver for full planet or should I upgrade the configurations?

(15 Feb, 19:18) subinjp7

Without any error information it's difficult to comment further...

(15 Feb, 21:26) SomeoneElse ♦

Sometimes it shows the tiles when requesting the tiles for multiple times. I am not sure what is the reason behind this.

In the RDS instance, the following errors are showing while requesting tiles,

:LOG: could not send data to client: Connection timed out or LOG: could not receive data from client: Connection reset by peer

(15 Feb, 21:48) subinjp7
1

Does dmesg show "Out of memory" messages?

(16 Feb, 14:09) scai ♦

No such messages...But while uploading the database, I have got many warning messages such as

NOTICE: Self-intersection at or near point 0.68302757542791204 46.349042878781603.

Does it have any relation to the current situation.

(16 Feb, 14:42) subinjp7
showing 5 of 6 show 1 more comments

It sounds to me as if your system is working normally, but very slow. This means when you access a tile that has not been pre-rendered, renderd will attempt to render the tile on the fly, and that takes too long, then someone along the way gives up and closes the connection. For a world-wide database you must have your database on SSD, and ideally the database should be local to the rendering machine and not connected to over the network. Otherwise you incur too many latencies.

On a very slow system you can still make it work "a little" by pre-rendering lots of tiles (see render_list), however you cannot pre-render the world on all zoom levels.

permanent link

answered 16 Feb, 00:23

Frederik%20Ramm's gravatar image

Frederik Ramm ♦
66.2k806121025
accept rate: 24%

Thanks for your answer. But I would like to ask one more question. I upgraded my EC2 instance and tried to render it. When I tried to render following tiles with zoom level 10, it failed. example.com/10/536/378.png

But when I tried again to render the same tiles with zoom level 12 it worked and then I could render the tiles with zoom level 10 also. I am not sure what is the problem with this.Do you have any idea about this?

(16 Feb, 09:48) subinjp7
1

You've said "it failed", but haven't said what messages occurred in the syslog of the tile server related to tile generation between the "TILE START" and "TILE DONE" messages.

(16 Feb, 10:00) SomeoneElse ♦

I am not getting TILE DONE message when it is getting failed.

(16 Feb, 11:12) subinjp7

alt text

Please find the attached image here with. This is the error message showing file rendering a world map(example.com/0/0/0.png).

Does it have anything to do with database upload? Database has been uploaded successfully.

permanent link

answered 16 Feb, 10:50

subinjp7's gravatar image

subinjp7
16447
accept rate: 0%

edited 16 Feb, 10:52

Moreover I would like to add some more points. While uploading the database, I have got many warning messages such as NOTICE: Self-intersection at or near point 0.68302757542791204 46.349042878781603.

Does it have any relation to the current situation.

(16 Feb, 11:10) subinjp7

Depending on the speed of the system the "DONE TILE" might be minutes or hours later.

(16 Feb, 13:11) SomeoneElse ♦

Thank you for your answer.

How can I make sure that, connection is not getting closed in a short period of time? If I change the ModTileMissingRequestTimeout to a large value, can I avoid that situation?

Do you have any idea about the reason behind failing happens at some zoom levels(most of the time, low zoom levels)?

(16 Feb, 13:38) subinjp7

Yes, see Frederik's answer above. You're trying to use a hammer as a screwdriver and are wondering why none of the screws are going in properly.

Get it working on a local server or VPS first, then look for cloud services that actually meet the requirements.

(08 Mar, 10:49) SomeoneElse ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×357
×130
×83
×14
×3

question asked: 15 Feb, 10:17

question was seen: 793 times

last updated: 08 Mar, 10:50

powered by OSQA