Hello, I'm trying to setup a nominatim server like https://nominatim.openstreetmap.org/ but something is going wrong.

SCOPE: Have a nominatim server with all the planet indexed, a copy of nominatim.openstreetmap.org

SOFTWARE:

RHEL 7 64bit
PostgreSQL 9.6
Postigis 2.4
PHP 5.4.16
gcc-c++-4.8.5-16
libgcc-4.8.5-16
cpp-4.8.5-16
gcc-4.8.5-16
libgcc-4.8.5-16

HARDWARE:

32CPUs
64GB RAM
590GB storage

Trying to install the version 3.0.1 of Nominatim I'm having some difficulties to index all the planet. I've followed the steps in the documentation http://nominatim.org/release-docs/3.0.1/Install-on-Centos-7.html and the compiler doesn't report any error.

List of main attempt:

  • First Attempt: I've imported the Central america region by using the setup command ./utils/setup.php --osm-file /data/nominatim/Nominatim-3.0.1/data/central-america-latest.osm.bz2 --all --osm2pgsql-cache 38000 2>&1 | tee setup.log The import was a success! Searching for central america region the result appear as expected. So I decided to import the Australia using the update command ./utils/update.php --import-file /data/nominatim/Nominatim-3.0.1/data/australia-oceania-latest.osm.bz2 --osm2pgsql-cache 38000 &> australia.log Unfortunately after the import, searching for "Perth" or other Australian city, the result was empty. I've also tried the command /utils/update.php --index --index-instances 30 but the result was the same
  • Second Attempt: Removing the database I've imported the Antartica. After the import it works as expected, so I decided to import the Australia (again) but nothing. I've tried different times with different options but it was always a failure.
  • Third Attempt: After many imports I decided to import directly all the planet (http://ftp5.gwdg.de/pub/misc/openstreetmap/planet.openstreetmap.org/pbf/planet-latest.osm.pbf) with the setup script like the first attempt. The import miserably fails :(

I'm struggling to have a nominatim server up and running but I've no clue how to solve this issue.

I'm doing the importing in some step wrong? I've to do other command or step after the import?

Thanks in advance.

asked 13 Dec '17, 14:04

v0id_'s gravatar image

v0id_
11112
accept rate: 0%

1

If importing one country works, then your setup is pretty complete. Best if you delete the database before trying another import. You say for the full planet it fails. Do you see any error messages? In which step and how long after starting the import does it fail? Does the Postgresql server logfiles show any errors?

(13 Dec '17, 19:51) mtmail

Have you resolved the problem? I too have the same case as yours. I am not able to search any. It gives me no result.

(23 Jan '18, 17:17) swiftkey

Swiftkey: the user never answered so we were unable to help. Please post any error messages, the query you run and output you see and if you see warnings in the postgresql or webserver logfiles as a new question on either help.openstreetmap.org or preferably https://github.com/openstreetmap/Nominatim/issues

(23 Jan '18, 18:27) mtmail
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×565

question asked: 13 Dec '17, 14:04

question was seen: 1,051 times

last updated: 23 Jan '18, 18:28

powered by OSQA