Hi,

When I select a task with id editor and click start mapping, I'm asked to log in again (even though I already am). I log in again and I'm taken to the editor as usual (also showing in the top right corner, that I am logged in). However the pink borders of the selected square are not showing, so it's impossible to see what the boundaries of the square are. This is occurs in all projects for me. Never happened to me before today, also the prompt to login, while already being logged in, never happened before today.

does anyone know how I could fix this problem with the borders not showing?

thks

asked 31 Oct '17, 11:02

NoKnow's gravatar image

NoKnow
11112
accept rate: 0%

edited 31 Oct '17, 11:04

You say "select a task" - are you perhaps using some external site to get into OSM (perhaps a HOT one)?

(31 Oct '17, 11:50) SomeoneElse ♦

hi thks for the comment.

I am using the following url with a google chrome browser on a windows 10 system

http://tasks.hotosm.org/

am I supposed to use another?

(31 Oct '17, 11:55) NoKnow

It depends what you're doing :)

EDIT: See bhousel's answer below. You SHOULD see boxes for the task boundary. Previous partly incorrect comment follows:

Tasks at http://tasks.hotosm.org/ are external to OSM, so you won't see them, or the boxes around areas, there.

You're probably being asked to "log in again" because you're probably logged in to HOT, but not OSM.

Mapping places far away as part of HOT tasks is just one of many thousands of reasons that people edit OSM.

(31 Oct '17, 12:01) SomeoneElse ♦

right sure.

I'll go and ask the question with the hot site help section, thanks for info.

(31 Oct '17, 12:05) NoKnow

Hey @NoKnow, I've written about this on here: https://github.com/openstreetmap/iD/issues/4381

As far as I understand it, the issue occurs in Chrome browser only, and only for some users. The purple task boundary is a .gpx file loaded from another server. When iD is loaded over https and the gpx file is loaded via http, sometimes Chrome will block it as "mixed content". (If you open a Javascript console, you'll see a warning about it).

The solution is to use another browser for now, until the server hosting the task manager can be changed to serve these .gpx files over https.

permanent link

answered 31 Oct '17, 18:20

bhousel's gravatar image

bhousel
2.1k12428
accept rate: 38%

hi, thks for the comment. chrome was working for me before today. I also tried Opera, Edge and firefox today, but they all gave the same result as I described above.

(31 Oct '17, 21:45) NoKnow

I am having the exact same problem in both Firefox and Chrome. Started being a problem yesterday.

(31 Oct '17, 22:22) Taperina
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×298

question asked: 31 Oct '17, 11:02

question was seen: 2,036 times

last updated: 31 Oct '17, 23:13

powered by OSQA