I try to create a route thru Matyholweni Gate "https://www.openstreetmap.org/#map=19/-33.68052/25.79878" with "https://openrouteservice.org/directions?n1=-33.976855&n2=25.611663&n3=15&a=-33.982335,25.612864,-33.68047,25.798967&b=0&c=0&k1=en-US&k2=km" but the route does not go thru the gate. If I look at the gate object it is of type barrier:gate with access:yes What prevents me from routing thru the gate? Thanks, Thomas

asked 10 Oct, 21:11

thgx's gravatar image

thgx
263
accept rate: 0%

As an aside to this particular question - it's not a good idea to "tag for the router". It might be perfectly valid for a router not to route past a particular sort of barrier - or a conscious decision by whoever designed the router.

This doesn't sound like the problem here of course - from what you're saying the gate will always be raised to let cars through but lowered to stop elephants.

(11 Oct, 16:41) SomeoneElse ♦

If I look at https://www.openstreetmap.org/node/2124837867 (the gate where routing stops) it doesn't have any access tags so I'm not sure why you believe it is tagged "access=yes" I would suspect that routing will work once correct access tags are applied.

permanent link

answered 10 Oct, 22:11

SimonPoole's gravatar image

SimonPoole ♦
30.4k13238483
accept rate: 18%

Hi all, Thanks for your help. SimonPoole is right, there was no Access tag, my fault. I set the connection as adviced by zorglubu.

I took this working gate as an example https://www.openstreetmap.org/directions?engine=graphhopper_car&route=-33.56912%2C25.81125%3B-33.56833%2C25.81216#map=19/-33.56878/25.81170

I added Access:private and motorcar:yes to the gate: https://www.openstreetmap.org/api/0.6/node/2124837867/

I added access:yes to the tertiary Highway: https://www.openstreetmap.org/api/0.6/way/4281040

Still no success with GraphHopper car routing: https://www.openstreetmap.org/directions?engine=graphhopper_car&route=-33.68071%2C25.79759%3B-33.68040%2C25.79915

Any more ideas?

Thanks, Thomas

(11 Oct, 09:05) thgx
1

It might take some time (days or weeks) for a router to start using your changes to OSM - you'll need to be patient.

(11 Oct, 09:19) SomeoneElse ♦
1

The access=yes on the tertiary road is unnecessary. You should add access=yes to both barriers (https://www.openstreetmap.org/node/2124837867 and https://www.openstreetmap.org/node/2124837858).

(11 Oct, 10:05) scai ♦

Have a look at the barrier=gate to the East of your lift_gate. It clearly says access=private. Your software obviously will not route through there, eventhough it has the motorcar=yes tag which does not make sense. OSM wiki defines access=private as "Only with permission of the owner on an individual basis". ownership should be permissive for private toll roads.

permanent link

answered 11 Oct, 08:49

wilda69's gravatar image

wilda69
16914
accept rate: 10%

I added acces=private (see my "answer" below). Now I changed it to access=yes, still no success

(11 Oct, 09:15) thgx
2

Routing engines take a while to update (usually between a day and a month), so don't expect the change to take effect immediately.

(11 Oct, 09:58) Richard ♦

Looking at the routing engines on osm.org, most seem just fine with that gate. Only graphhopper's car routing struggles. Whether routing should stop at a gate on a tertiary road with no explicit access tags is a moot point - I'd suggest that it shouldn't, though whoever implements a router can do so if they wish.

permanent link

answered 10 Oct, 23:24

SomeoneElse's gravatar image

SomeoneElse ♦
27.7k61290644
accept rate: 15%

-2

Hello Thomas,

Zoom-in quite a lot, and move your gate exactly on the boundary. The colour of this boundary will change, indicating that it's sticking. Release the mouse bouton. Check by moving again the gate and CTRL-Z.

permanent link

answered 10 Oct, 22:02

zorglubu's gravatar image

zorglubu
242
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×116
×14
×1

question asked: 10 Oct, 21:11

question was seen: 118 times

last updated: 11 Oct, 16:41

powered by OSQA