I have a pretty embarrassing problem. Through some shortcut I activated a mode in JOSM where every time I add a new node with the “draw nodes tool”the screen jumps somewhat loosely into the direction of the newly added node. I have no idea, even after ridiculously long investigation I didn't find a way to turn this feature off. This is totally annoying, as it jumps 40% of the time into a direction I don't want.

Does anybody know how this is called, how to turn it off and speculate why it turned on in the first time? Your help is really appreciated!

asked 09 Oct, 11:53

bkn_jap's gravatar image

bkn_jap
465
accept rate: 0%


Sounds like you've activated View -> Viewport following (CTRL-SHIFT-F).

permanent link

answered 09 Oct, 12:05

scai's gravatar image

scai ♦
29.1k17255408
accept rate: 23%

2

The feature was originally implemented to ease the tracing of very long and almost-straight features like fences or power lines, where it reduces the required amount of mouse moving drastically. In almost any other situation it is guaranteed to drive the user nuts ;)

(09 Oct, 12:20) Frederik Ramm ♦
1

Thanks a lot! According to the GUI it was turned off, but turning it on and off again did the trick. Much more comfortable mapping now :-)

(09 Oct, 15:32) bkn_jap
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×410
×118
×21
×5

question asked: 09 Oct, 11:53

question was seen: 148 times

last updated: 09 Oct, 15:32

powered by OSQA