Today did a 9 mile walk and a lots of route as not been mapped into OSM. For some reason my garmin trace as a problem it won't open with my downloading software (memory map) it looks ok in a text editor, much like the dozens I've uploaded before,I tried memory card down load as well no luck. I have linux and windows available what could I chop or clean up this with and save as a GPX it was a nice walk but don't want to go there again for a while. I can use bing to map some but that is not ideal.any ideas

asked 26 Jun '11, 00:43

andy%20mackey's gravatar image

andy mackey
11.5k73125255
accept rate: 4%

edited 11 Aug '14, 08:49

note the file does have usual list of lat lons and time stamps

(26 Jun '11, 00:45) andy mackey

"Not well-formed (invalid token)" sounds like there's something in the XML that shouldn't be there.

I'd suggest you run the file through an online XML validator, such as this one. If there's a problem with the XML, it will tell you what it is.

permanent link

answered 26 Jun '11, 12:11

Richard's gravatar image

Richard ♦
27.2k40241360
accept rate: 19%

Thanks Richard your link was so easy to use found the same faulty line as foxe but more detail.I edited to make it look like other lines' syntax in Notepad++ but then struggled to change file extension back from TXT to GPX. the file now opens ok and I will upload it tomorrow.very pleased thought i may have lost the trace.thanks also to Vclaw

(26 Jun '11, 16:47) andy mackey

Richard that link doesn't work at the moment

(22 Dec '16, 23:40) andy mackey
1

@andy mackey: according to the Internet Archive's snapshot it is down since about Sept. 2015.

Instead, I would suggest to use the W3C Markup Validator.

(23 Dec '16, 00:24) aseerel4c26 ♦

Thanks, aseerel4c26 i have just worked out why todays trace wouldn't work see new answer

(23 Dec '16, 00:39) andy mackey

Have you tried uploading the GPX to openstreetmap.org? Does it work, or does it give any sort of error?

Or you could try opening the GPX file in JOSM (without uploading it). If that works, you can then trace the path etc to add it to the map.

If these don't work, to try and fix the GPX you could:

  • Process it using GPXBabel. ie set the input and output formats to GPX, this might fix it.

  • Open it in an XML editor. Foxe is a good free option for Windows. This has syntax highlighting, so it should make it easier to spot any errors in the tags. It has an option to validate the file, which should warn of any errors in it.

permanent link

answered 26 Jun '11, 02:41

Vclaw's gravatar image

Vclaw
9.1k891140
accept rate: 22%

Thanks Vclaw I'll try your suggestions and report back

(26 Jun '11, 06:25) andy mackey

this is what babel returned..... gpsbabel -w -r -t -i gpx -f C:/Documents and Settings/Compaq_Owner/My Documents/AA GPX TRACKS/AA newest file/20110625.gpx -o gpx -F C:/Documents and Settings/Compaq_Owner/barnwell.gpx -o gpx -F C:/DOCUME~1/COMPAQ~1/LOCALS~1/Temp/qt_temp.Hp3396 GPX: XML parse error at line 31228 of 'C:/Documents and Settings/Compaq_Owner/My Documents/AA GPX TRACKS/AA newest file/20110625.gpx' : not well-formed (invalid token)

Error running gpsbabel: Process exited unsucessfully with code 1

(26 Jun '11, 06:43) andy mackey

josm loaded part of file

(26 Jun '11, 06:46) andy mackey

found foxe a little awkward if I had tried harder I'm sure it would have done it

(26 Jun '11, 16:35) andy mackey

If I load a trace from switched on gps it can be a problem (as its still active)from a memory card it works better as its switched off

(17 Jul '11, 11:28) andy mackey

I just experienced a problem with a trace i couldn't open with my usual programmes. I then notice the memory on my Garmin Oregon's memory was full and it had stopped recording mid location. i should have saved and deleted stuff. I eventually opened the incomplete file with Notepad a text editor, i compared it with a good one, the last sentence was incomplete so i cut and pasted a good ending. so it ended like this:

<trkpt lat="52.0698085341" lon="-0.1248275572"></trkpt>
</trkseg>
</trk>
</gpx>

saved it and then it worked, apart from the fact the point was from a previous walk of course several KM away.

permanent link

answered 23 Dec '16, 00:57

andy%20mackey's gravatar image

andy mackey
11.5k73125255
accept rate: 4%

edited 23 Dec '16, 01:23

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16236548

You can also use Liquid XML Editor to validate your xml file, its not free but then you get a much more fluid UI and syntax highlighting.

permanent link

answered 17 Aug '11, 13:48

Michael%20Dupre's gravatar image

Michael Dupre
1
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×218
×68
×37
×10

question asked: 26 Jun '11, 00:43

question was seen: 16,777 times

last updated: 23 Dec '16, 01:23

powered by OSQA