NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I recently passed through an area, and OSM showed I should turn left to keep going. The problem was "turning left" meant ascending about 40' upward onto an overpass.

I saw that OSM didn't have SR-626/Cary Street setup with a bridge over SR-10, so I logged into OSM and put a bridge there. The bridge shows up now, but it still wants you to "turn left". I don't understand how to resolve the issue, I'm still learning about editing, and didn't want to break something. Here's a link showing what I am talking about:

asked 27 May '17, 00:14

taz2015's gravatar image

accept rate: 0%

For info: This was fixed 24th May but routing was still failing this morning of 29th (judging by Max's comment ) but when i tried it a few hours later it worked as we hoped. So five days wait which is similar to the couple of times i have waited in the past.

(29 May '17, 21:57) andy mackey

The bridge itself is correct, but it should be the only connection between the roads on either side, they are still connected underneath it. For this particular situation, the fix is to right click on the point connecting the roads and then select Delete (the trashcan). I've left it for you to take a look at.

It can also take some days for new edits to be accounted for in the routes.

permanent link

answered 27 May '17, 01:36

maxerickson's gravatar image

accept rate: 32%

Thanks, very helpful. I now see that it routes properly over the bridge using all of the routing options available except one--OSRM can't find its way across.

I'm not sure if I should create a new question for that, or if you can point me in the right direction?

(29 May '17, 00:47) taz2015

I imagine it just hasn't picked up the new data. It is under fairly active development and when there is a hiccup in the data processing stage, it just sticks with the previous (successfully processed) version of the data. I looked at the edit, I think it is fine, OSRM just needs to notice it.

(29 May '17, 02:01) maxerickson

It works correctly now. It can seem a long delay when waiting to see if a fix as worked, but once you have experienced the wait you know what to expect in future.

(29 May '17, 16:25) andy mackey

Yeah I figured it would take time, which is why I'm only checking once a day or so. I just checked again, but OSRM isn't seeing the route still (for me). I figured the route calculation was server-side, and had nothing to do with a local cache--am I incorrect?

(30 May '17, 00:00) taz2015

If the other engines are picking it up but OSRM isn't, the issue is almost certainly with OSRM. As you can see from and the OSRM demo server is currently having some issues. Don't stress about it, it'll be fixed in time.

(30 May '17, 14:48) Richard ♦

No worries for sure, just curious. I figured the route itself was fine since the other engines worked. The situation just irked me some, but glad to see it's resolved :)

(31 May '17, 22:49) taz2015
showing 5 of 6 show 1 more comments

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 27 May '17, 00:14

question was seen: 2,247 times

last updated: 31 May '17, 22:49

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum