I made a large quantity of small edits straightening roads and paths. Now when I try to save, I have no save button. If if close my browser and reopen, it allows me to restore my edits, but still the save buttons is gone. I am using Firefox 53.0.2 on Windows 7.

Screenshot

asked 13 May, 18:33

Ben%20Boldt's gravatar image

Ben Boldt
29337
accept rate: 0%

edited 13 May, 19:06

scai's gravatar image

scai ♦
29.1k17255408

Ben, which editor did you use to make the edits in OSM ?

(14 May, 10:06) Hendrikklaas

I use the iD in-browser editor. Normally the save button is there. I have made many edits in the iD editor successfully before, but for some reason now it has disappeared.

(15 May, 17:35) Ben Boldt

I am having the same issue. Running Chrome 58.0.3029.110 in Win7

These are the first changes I have tried saving on this laptop (I've retired the one I was previously using). Significantly, I was using iD 2.2.0 on my previous machine - I see that 2.2.1 is currently loaded on my current one.

If I back my save attempt out (I use "Show My Location" to do that, since there's no "Cancel" button now either), the changeset comment still floats in the side frame and doesn't go away.

(15 May, 18:11) GregRetro

And just to be clear, there's no changelog shown in the left panel when saving either. Just the changeset comment window - that's it. iD is also now having problems rendering when I move around the map.

(15 May, 18:52) GregRetro
1

Well... I'm not sure why, but I lost my changes after my 4th browser restart. Obviously not happy about that... but the issues with saving are not presenting anymore. No more problems with rendering on the editable map either.
Feh. 2.2.0 was beautifully smooth - I'm hoping this is a very isolated issue in 2.2.1.

(15 May, 20:34) GregRetro

There is a recent? change of a changeset having a maximum capacity (currently 10,000 edits). Could yours be bigger and iD not able to manage it?
Josm handles a bigger changeset by splitting into smaller pieces on upload.
http://wiki.openstreetmap.org/wiki/Changeset

(17 May, 02:59) nevw

Not the case for me at least. I usually have no more than 1000-1200 node edits per save, and looking through past changesets on Pascal's site, I don't see a single one that has gone above 1700 nodes.

(17 May, 21:44) GregRetro
showing 5 of 7 show 2 more comments

I've opened https://github.com/openstreetmap/iD/issues/4108 to track this issue.

If you are able, please comment there with your browser and os details. If the issue is repeatable, and you can open a developer console in your browser and let me know whatever JavaScript errors you see, that's really the best way to determine the root cause. Thanks!

permanent link

answered 21 Jun, 15:07

bhousel's gravatar image

bhousel
1.5k11720
accept rate: 36%

Perhaps it's just a rendering problem. Try making the text size smaller (place the mouse pointer over the light panel on the left, hold Ctrl, and scroll down with the mousewheel). Try pressing Enter or Ctrl+Enter after entering a changeset comment.

permanent link

answered 14 May, 12:57

dsh4's gravatar image

dsh4
65651126
accept rate: 5%

I tried zooming the window in and out using ctrl+scroll wheel. The entire window did zoom, but the save button did not reappear.

I tried pressing ctrl + enter and it had no effect. Pressing enter normally just adds a new line.

(15 May, 17:34) Ben Boldt

I also have tried pressing tab to cycle through selecting elements in my browser, pressing space at any invisible element to invoke it. I did not find a save button this way.

Each time I open my browser and go to OSM, it prompts me that I have unsaved edits, and I choose to "restore". This does restore my edits each time. I have not tried discarding my edits, but as you can see, I have a large number of edits that I would prefer not to lose.

I also have tried making a change after restoring, so as to "touch" the data in case it is not marked as being changed. This does not bring back the save button either.

I have had Adblock Plus running all along, and the save button worked fine with it before. I tried turning off Adblock Plus with no effect. Save button still gone.

I rebooted the computer, no difference.

I'm not sure what to try next.

(15 May, 18:01) Ben Boldt
1

I would suggest disabling any other FF plugins and testing, further checking it it works with Chrome on the same machine.

In nay case it seems that this may be a regression and you should open an issue on the iD issue tracker (as there are limits to what we can do for you here).

(15 May, 20:15) SimonPoole ♦
1

I ended up discarding my changes, and now it works fine. I was able to make changes and successfully save them.

Could it be that I had unsaved changes, then there was an update to iD before I saved, and then the new version of iD was not compatible with my existing changes?

(17 May, 00:04) Ben Boldt

@Ben Boldt as I pointed out further up, question/issues wrt the inner workings of iD really need to go the iD issue tracker.

(19 May, 08:40) SimonPoole ♦

Hi Simon, I worked around this bug, so I'm okay now myself. I don't really take requests to do additional work here, such as using an issue tracker. If you or anyone else wish to track this, please feel free to do so with the additional comments that I have provided, otherwise we can just leave it here for future reference.

(19 May, 18:47) Ben Boldt
showing 5 of 6 show 1 more comments

This happened to me again - laptop rebooted overnight before I had saved a bunch of changes.
I know, mea culpa. But I found a fix/workaround!
ROOT CAUSE: iD had updated to 2.2.2, and although most of my changes came back, only the changeset comment dialogue box was available upon trying to save - no save button - and the dialogue box would not go away and rendered the left frame unusable. So I can definitively say that the restoration of unsaved changes from a previous iD version is the issue. In other words, you can't save changes from iD 2.2.1 in a browser session using iD 2.2.2.

FIX: Control-Z (or use the Undo button) for ALL of the changes that are cached in your session, until the Undo button is no longer lit. Then, CTRL-Y (or Redo) all of the changes over again. You may have to mash that button for quite a while... This will redo all of your edits in the current version of iD, and saving will be re-enabled.
Sooooo glad this workaround actually worked - and I've learned a valuable lesson that I should have learned the first time. <redfaced>

(Simon - I've posted here instead of to iD development since this question is still here, and in my opinion is now resolved)

permanent link

answered 14 Jun, 18:15

GregRetro's gravatar image

GregRetro
1153511
accept rate: 50%

edited 14 Jun, 18:18

I had this happen a second time to me a couple of days ago. It appears that this is the sequence to trigger the bug:

  • Make changes with iD editor
  • Close the browser window without saving
  • iD gets updated to a newer version while you're away
  • Come back later and choose to restore your unsaved edits

At this point, save will not work. You must close the browser window, reopen, and choose not to restore. Then Save will work again.

permanent link

answered 14 Jul, 18:27

Ben%20Boldt's gravatar image

Ben Boldt
29337
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×224
×40

question asked: 13 May, 18:33

question was seen: 1,041 times

last updated: 14 Jul, 18:27

powered by OSQA