"remote control" is enabled in JOSM.

When I choose the JOSM link from KEEPRIGHT I get a flicker of text across the bottom of the screen that reads

https://localhost:8112/loan_and_zoom?left=.......&zoom_mode=download"

The link from KEEPRIGHT to id works fine.

I'm using JSOM stable version 11826 on a PC running windows 10 and the chrome browser

asked 16 Apr, 22:47

Alan01730's gravatar image

Alan01730
219141629
accept rate: 0%

edited 17 Apr, 16:29

aseerel4c26's gravatar image

aseerel4c26 ♦
28.0k12208480

2

I should mention that the link from whodidit to josm does work.

(16 Apr, 22:51) Alan01730

Does your JOSM remote control via HTTPS work with other sites? E.g. with osm.org? I guess not.

  1. Did you enable HTTPS in the JOSM remote control settings?
  2. Did you once accept the JOSM certificate for this connection in your browser (see https://josm.openstreetmap.de/wiki/Help/Preferences/RemoteControl )?
permanent link

answered 16 Apr, 22:59

aseerel4c26's gravatar image

aseerel4c26 ♦
28.0k12208480
accept rate: 17%

edited 18 Apr, 21:25

1

enabling HTTPS in the JOSM remote control settings solved the problem.

(17 Apr, 02:09) Alan01730

Semi-related question: JOSM remote control broke recently for me. . . Looking into it I see that even though I have HTTPS enabled in the JOSM preferences it is not actually listening to port 8112. It is listening on port 8111 (the non-HTTPS port).

I see nothing in the Macintosh firewall settings that seem like they will affect this. Disabling the Macintosh firewall does not fix the issue. I've save some older versions of JOSM which I know worked and they have the same issue, so I don't think it is a bug in the current JOSM release.

That leaves me with Java. And thinking back on the timing, it could be that JOSM remote control has been broken since I updated to Java 8 Update 121. I don't see anything that seems like it would affect this in the Java control panel. The Java control panel tells me that I have the correct version for my computer.

Any suggestions? (My work around at present is to reopen www.openstreetmap.org using http:// rather than https:// and then the edit button works).

permanent link

answered 17 Apr, 16:55

stf's gravatar image

stf
5.4k74589
accept rate: 18%

stf, could you please open a new question entry for this. You know how this site works, don't you? :-) You can link to this question in your question text if you think it is related.

(17 Apr, 20:07) aseerel4c26 ♦

Same problem with me. OSMOSE works fine but Keepright will not open in JOSM. I accepted the JOSM certificate. Two weeks ago it worked fine. Nothing has been changed on my PC. HTTPS in the JOSM remote control settings does not solve the problem.

René

permanent link

answered 18 Apr, 14:23

rivw's gravatar image

rivw
112
accept rate: 0%

edited 18 Apr, 14:30

I solved the problem. Click with your right mouse button on the JOSM link in Keepright and choose "open link in a new window". You will see that this page has no secure connection. If you make an exception for this page, so it works without certificate, you will have the connection between Keepright and JOSM again working.

(18 Apr, 14:45) rivw
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×12
×11

question asked: 16 Apr, 22:47

question was seen: 114 times

last updated: 18 Apr, 21:25

powered by OSQA